aboutsummaryrefslogtreecommitdiffstats
path: root/cipher/blowfish.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-03-20 00:39:44 +0000
committerDavid Shaw <[email protected]>2006-03-20 00:39:44 +0000
commit0f4f660d5fc036af56d20d988bfc23a52dffd158 (patch)
tree4d7e8b764ca7a422c5a847f6b5311344fc9d1aad /cipher/blowfish.c
parent* configure.ac: Allow the DNS stuff to work on OSX by trying the (diff)
downloadgnupg-0f4f660d5fc036af56d20d988bfc23a52dffd158.tar.gz
gnupg-0f4f660d5fc036af56d20d988bfc23a52dffd158.zip
* blowfish.c, md5.c, rmd160.c, sha1.c, sha256.c, sha512.c: Use '#if'
rather than '#ifdef' BIG_ENDIAN_HOST. Harmless as we explicitly define BIG_ENDIAN_HOST to 1 when we need it, but needed for OSX fat builds when we define BIG_ENDIAN_HOST to another macro.
Diffstat (limited to 'cipher/blowfish.c')
-rw-r--r--cipher/blowfish.c6
1 files changed, 3 insertions, 3 deletions
diff --git a/cipher/blowfish.c b/cipher/blowfish.c
index 1a1ce5678..1d33bbb8d 100644
--- a/cipher/blowfish.c
+++ b/cipher/blowfish.c
@@ -251,7 +251,7 @@ function_F( BLOWFISH_context *bc, u32 x )
{
u16 a, b, c, d;
-#ifdef BIG_ENDIAN_HOST
+#if BIG_ENDIAN_HOST
a = ((byte*)&x)[0];
b = ((byte*)&x)[1];
c = ((byte*)&x)[2];
@@ -267,7 +267,7 @@ function_F( BLOWFISH_context *bc, u32 x )
}
#endif
-#ifdef BIG_ENDIAN_HOST
+#if BIG_ENDIAN_HOST
#define F(x) ((( s0[((byte*)&x)[0]] + s1[((byte*)&x)[1]]) \
^ s2[((byte*)&x)[2]]) + s3[((byte*)&x)[3]] )
#else
@@ -528,7 +528,7 @@ do_bf_setkey( BLOWFISH_context *c, const byte *key, unsigned keylen )
}
for(i=j=0; i < BLOWFISH_ROUNDS+2; i++ ) {
-#ifdef BIG_ENDIAN_HOST
+#if BIG_ENDIAN_HOST
((byte*)&data)[0] = key[j];
((byte*)&data)[1] = key[(j+1)%keylen];
((byte*)&data)[2] = key[(j+2)%keylen];