aboutsummaryrefslogtreecommitdiffstats
path: root/agent/query.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2002-09-26 07:10:56 +0000
committerWerner Koch <[email protected]>2002-09-26 07:10:56 +0000
commit2d432afff653239ef73c97fdecfff2df1622c62d (patch)
tree3a79b85af1e07965da9043f43dc7e23c39187988 /agent/query.c
parent* Makefile.am: Link gpg with EGDLIBS (i.e. NETLIBS) as EGD uses sockets. (diff)
downloadgnupg-2d432afff653239ef73c97fdecfff2df1622c62d.tar.gz
gnupg-2d432afff653239ef73c97fdecfff2df1622c62d.zip
* gpg-agent.c (handle_signal): Flush cache on SIGHUP.
* cache.c (agent_flush_cache): New. * gpg-agent.c, agent.h: Add --keep-display and --keep-tty. * query.c (start_pinentry): Implement them. The option passing needs more thoughts.
Diffstat (limited to 'agent/query.c')
-rw-r--r--agent/query.c6
1 files changed, 3 insertions, 3 deletions
diff --git a/agent/query.c b/agent/query.c
index c461a55ce..ee18a1483 100644
--- a/agent/query.c
+++ b/agent/query.c
@@ -113,7 +113,7 @@ start_pinentry (void)
/* FIXME: We must do this thread specific */
argv[0] = pgmname;
- if (opt.display)
+ if (opt.display && !opt.keep_display)
{
argv[1] = "--display";
argv[2] = opt.display;
@@ -150,7 +150,7 @@ start_pinentry (void)
NULL, NULL, NULL, NULL, NULL, NULL);
if (rc)
return unlock_pinentry (map_assuan_err (rc));
- if (opt.ttyname)
+ if (opt.ttyname && !opt.keep_tty)
{
char *optstr;
if (asprintf (&optstr, "OPTION ttyname=%s", opt.ttyname) < 0 )
@@ -161,7 +161,7 @@ start_pinentry (void)
if (rc)
return unlock_pinentry (map_assuan_err (rc));
}
- if (opt.ttytype)
+ if (opt.ttytype && !opt.keep_tty)
{
char *optstr;
if (asprintf (&optstr, "OPTION ttytype=%s", opt.ttytype) < 0 )