aboutsummaryrefslogtreecommitdiffstats
path: root/agent/query.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2002-01-19 18:19:47 +0000
committerWerner Koch <[email protected]>2002-01-19 18:19:47 +0000
commit6af684c11856bb8cbb4716ef6ca378d8c8858063 (patch)
tree08d1e60e1e257352aa1d976d3023bb3310de5d7e /agent/query.c
parent* import.c (gpgsm_import): Just do a basic cert check before (diff)
downloadgnupg-6af684c11856bb8cbb4716ef6ca378d8c8858063.tar.gz
gnupg-6af684c11856bb8cbb4716ef6ca378d8c8858063.zip
* gpg-agent.c: Removed unused cruft and implement the socket
based server. (my_strusage): Take bug report address from configure.ac. * command.c (start_command_handler): Add an argument to start as regular server. (start_command_handler): Enable Assuan logging.
Diffstat (limited to '')
-rw-r--r--agent/query.c1
1 files changed, 1 insertions, 0 deletions
diff --git a/agent/query.c b/agent/query.c
index 1b90c49e1..45fcbfd8e 100644
--- a/agent/query.c
+++ b/agent/query.c
@@ -268,6 +268,7 @@ agent_get_passphrase (char **retpass, const char *desc, const char *prompt,
if (!parm.buffer)
return seterr (Out_Of_Core);
+ assuan_begin_confidential (entry_ctx);
rc = assuan_transact (entry_ctx, "GETPIN", getpin_cb, &parm, NULL, NULL);
if (rc)
{