aboutsummaryrefslogtreecommitdiffstats
path: root/agent/gpg-agent.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-12-19 13:38:24 +0000
committerWerner Koch <[email protected]>2004-12-19 13:38:24 +0000
commite73100a940f7115e4be9f34dca160f622d869005 (patch)
treea9d2248892a8b132e4a2fcafa5dce270ab2d48a8 /agent/gpg-agent.c
parent* configure.ac (AH_BOTTOM): Define EXEEXT_S. (diff)
downloadgnupg-e73100a940f7115e4be9f34dca160f622d869005.tar.gz
gnupg-e73100a940f7115e4be9f34dca160f622d869005.zip
* maperror.c (map_assuan_err_with_source): Oops, args were swapped.
* w32-pth.c (pth_init): Enable debugging depending on env var.
Diffstat (limited to 'agent/gpg-agent.c')
-rw-r--r--agent/gpg-agent.c6
1 files changed, 6 insertions, 0 deletions
diff --git a/agent/gpg-agent.c b/agent/gpg-agent.c
index dfa457282..ed12fed4f 100644
--- a/agent/gpg-agent.c
+++ b/agent/gpg-agent.c
@@ -437,14 +437,20 @@ main (int argc, char **argv )
/* Libgcrypt requires us to register the threading model first.
Note that this will also do the pth_init. */
#ifdef USE_GNU_PTH
+#ifdef HAVE_W32_SYSTEM
+ /* For W32 we need pth. */
+ pth_init ();
+#else
err = gcry_control (GCRYCTL_SET_THREAD_CBS, &gcry_threads_pth);
if (err)
{
log_fatal ("can't register GNU Pth with Libgcrypt: %s\n",
gpg_strerror (err));
}
+#endif
#endif /*USE_GNU_PTH*/
+
/* Check that the libraries are suitable. Do it here because
the option parsing may need services of the library. */
if (!gcry_check_version (NEED_LIBGCRYPT_VERSION) )