aboutsummaryrefslogtreecommitdiffstats
path: root/agent/gpg-agent.c
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2009-10-16 18:35:03 +0000
committerMarcus Brinkmann <[email protected]>2009-10-16 18:35:03 +0000
commitde563fdeb5078fec5b8ffb24a0fe07c0aa016bbb (patch)
treea9f9cd0560772255708c4fdf6bce95221d983629 /agent/gpg-agent.c
parentSomehow this slipped through. Really commit this time. (diff)
downloadgnupg-de563fdeb5078fec5b8ffb24a0fe07c0aa016bbb.tar.gz
gnupg-de563fdeb5078fec5b8ffb24a0fe07c0aa016bbb.zip
2009-10-16 Marcus Brinkmann <[email protected]>
* configure.ac: Check for libassuan instead of libassuan-pth. common/ 2009-10-16 Marcus Brinkmann <[email protected]> * Makefile.am (libcommon_a_CFLAGS): Use LIBASSUAN_CFLAGS instead of LIBASSUAN_PTH_CFLAGS. scd/ 2009-10-16 Marcus Brinkmann <[email protected]> * AM_CFLAGS, scdaemon_LDADD: Use libassuan instead of libassuan-pth. * scdaemon.c: Invoke ASSUAN_SYSTEM_PTH_IMPL. (main): Call assuan_set_system_hooks and assuan_sock_init. g13/ 2009-10-16 Marcus Brinkmann <[email protected]> * AM_CFLAGS, g13_LDADD: Use libassuan instead of libassuan-pth. * g13.c: Invoke ASSUAN_SYSTEM_PTH_IMPL. (main): Call assuan_set_system_hooks. agent/ 2009-10-16 Marcus Brinkmann <[email protected]> * gpg_agent_CFLAGS, gpg_agent_LDADD: Use libassuan instead of libassuan-pth. * gpg-agent.c: Invoke ASSUAN_SYSTEM_PTH_IMPL. (main): Call assuan_set_system_hooks and assuan_sock_init. Fix invocation of assuan_socket_connect.
Diffstat (limited to 'agent/gpg-agent.c')
-rw-r--r--agent/gpg-agent.c7
1 files changed, 5 insertions, 2 deletions
diff --git a/agent/gpg-agent.c b/agent/gpg-agent.c
index 4493c7abd..be7da2009 100644
--- a/agent/gpg-agent.c
+++ b/agent/gpg-agent.c
@@ -50,7 +50,6 @@
#include "gc-opt-flags.h"
#include "exechelp.h"
-
enum cmd_and_opt_values
{ aNull = 0,
oCsh = 'c',
@@ -276,6 +275,8 @@ static void check_own_socket (void);
static int check_for_running_agent (int silent, int mode);
/* Pth wrapper function definitions. */
+ASSUAN_SYSTEM_PTH_IMPL;
+
GCRY_THREAD_OPTION_PTH_IMPL;
static int fixed_gcry_pth_init (void)
{
@@ -593,6 +594,8 @@ main (int argc, char **argv )
assuan_set_malloc_hooks (&malloc_hooks);
assuan_set_assuan_log_prefix (log_get_prefix (NULL));
assuan_set_gpg_err_source (GPG_ERR_SOURCE_DEFAULT);
+ assuan_set_system_hooks (ASSUAN_SYSTEM_PTH);
+ assuan_sock_init ();
setup_libgcrypt_logging ();
gcry_control (GCRYCTL_USE_SECURE_RNDPOOL);
@@ -2217,7 +2220,7 @@ check_for_running_agent (int silent, int mode)
rc = assuan_new (&ctx);
if (! rc)
- rc = assuan_socket_connect (&ctx, infostr, pid);
+ rc = assuan_socket_connect (ctx, infostr, pid);
xfree (infostr);
if (rc)
{