aboutsummaryrefslogtreecommitdiffstats
path: root/agent/gpg-agent.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-04-06 10:01:04 +0000
committerWerner Koch <[email protected]>2004-04-06 10:01:04 +0000
commitd84d632583c1c61180d40ce9b91f185160ab02d6 (patch)
tree95f50ee6802e523b69a99d7bd49405e715923e55 /agent/gpg-agent.c
parentAdd STATUS_NEWSIG (diff)
downloadgnupg-d84d632583c1c61180d40ce9b91f185160ab02d6.tar.gz
gnupg-d84d632583c1c61180d40ce9b91f185160ab02d6.zip
* configure.ac: Require libgcrypt 1.1.94.
Introduce PACKAGE_GT and set it to gnupg2. * gpg-agent.c (main): Use new libgcrypt thread library register scheme. * Makevars (DOMAIN): Init from PACKAGE_GT
Diffstat (limited to '')
-rw-r--r--agent/gpg-agent.c8
1 files changed, 4 insertions, 4 deletions
diff --git a/agent/gpg-agent.c b/agent/gpg-agent.c
index dd35bfcdf..0fc1bb8bf 100644
--- a/agent/gpg-agent.c
+++ b/agent/gpg-agent.c
@@ -197,12 +197,12 @@ static void
i18n_init (void)
{
#ifdef USE_SIMPLE_GETTEXT
- set_gettext_file( PACKAGE );
+ set_gettext_file( PACKAGE_GT );
#else
#ifdef ENABLE_NLS
setlocale (LC_ALL, "");
- bindtextdomain (PACKAGE, LOCALEDIR);
- textdomain (PACKAGE);
+ bindtextdomain (PACKAGE_GT, LOCALEDIR);
+ textdomain (PACKAGE_GT);
#endif
#endif
}
@@ -649,7 +649,7 @@ main (int argc, char **argv )
easier to switch only once instead of for every message and it
actually helps when more then one thread is active (avoids an
extra copy step). */
- bind_textdomain_codeset (PACKAGE, "UTF-8");
+ bind_textdomain_codeset (PACKAGE_GT, "UTF-8");
#endif
/* now start with logging to a file if this is desired */