aboutsummaryrefslogtreecommitdiffstats
path: root/agent/gpg-agent.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-12-21 10:03:00 +0000
committerWerner Koch <[email protected]>2004-12-21 10:03:00 +0000
commit878cf2076633742ad5f4e4008059b0fc8d776d37 (patch)
tree07e7c9d7bab4f56a69d5496cede7ab6a3f36397a /agent/gpg-agent.c
parent* configure.ac: Add PATHSEP_C and PATHSEP_S. For W32 let all (diff)
downloadgnupg-878cf2076633742ad5f4e4008059b0fc8d776d37.tar.gz
gnupg-878cf2076633742ad5f4e4008059b0fc8d776d37.zip
* gpg-agent.c (main): Use default_homedir().
* protect-tool.c (main): Ditto. * signal.c (got_fatal_signal, got_usr_signal) (got_fatal_signal) [DOSISH]: Don't build. * simple-gettext.c: Include sysutils.h * homedir.c: New. * Makefile.am (libcommon_a_SOURCES): Add it. (EXTRA_DIST): Removed mkerror and mkerrtok. * gpgv.c, g10.c (main): Use default_hoemdir (). * scdaemon.c (main): Use default_homedir(). * gpgsm.c (main): Use default_homedir().
Diffstat (limited to '')
-rw-r--r--agent/gpg-agent.c9
1 files changed, 1 insertions, 8 deletions
diff --git a/agent/gpg-agent.c b/agent/gpg-agent.c
index 911afb881..2c3d834a5 100644
--- a/agent/gpg-agent.c
+++ b/agent/gpg-agent.c
@@ -478,15 +478,8 @@ main (int argc, char **argv )
if (shell && strlen (shell) >= 3 && !strcmp (shell+strlen (shell)-3, "csh") )
csh_style = 1;
+ opt.homedir = default_homedir ();
- opt.homedir = getenv("GNUPGHOME");
-#ifdef HAVE_W32_SYSTEM
- if (!opt.homedir || !*opt.homedir)
- opt.homedir = read_w32_registry_string (NULL,
- "Software\\GNU\\GnuPG", "HomeDir");
-#endif /*HAVE_W32_SYSTEM*/
- if (!opt.homedir || !*opt.homedir)
- opt.homedir = GNUPG_DEFAULT_HOMEDIR;
/* Check whether we have a config file on the commandline */
orig_argc = argc;