aboutsummaryrefslogtreecommitdiffstats
path: root/agent/genkey.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2005-05-24 12:37:36 +0000
committerWerner Koch <[email protected]>2005-05-24 12:37:36 +0000
commite96af3715b9b126b435c7887e47a660a73bf237b (patch)
tree2cc95e397aa1a3f65016a0b8c15546f430e10060 /agent/genkey.c
parent* Makefile.am: Do not build sc-copykeys anymore. (diff)
downloadgnupg-e96af3715b9b126b435c7887e47a660a73bf237b.tar.gz
gnupg-e96af3715b9b126b435c7887e47a660a73bf237b.zip
* call-scd.c (inq_needpin): Skip leading spaces in of PIN
description. * divert-scd.c (getpin_cb): Enhanced to cope with description flags. * query.c (agent_askpin): Add arg PROMPT_TEXT. Changed all callers.
Diffstat (limited to '')
-rw-r--r--agent/genkey.c8
1 files changed, 4 insertions, 4 deletions
diff --git a/agent/genkey.c b/agent/genkey.c
index 17d85f77c..e07518d5a 100644
--- a/agent/genkey.c
+++ b/agent/genkey.c
@@ -120,11 +120,11 @@ agent_genkey (CTRL ctrl, const char *keyparam, size_t keyparamlen,
pi2->check_cb_arg = pi->pin;
next_try:
- rc = agent_askpin (ctrl, text1, initial_errtext, pi);
+ rc = agent_askpin (ctrl, text1, NULL, initial_errtext, pi);
initial_errtext = NULL;
if (!rc)
{
- rc = agent_askpin (ctrl, text2, NULL, pi2);
+ rc = agent_askpin (ctrl, text2, NULL, NULL, pi2);
if (rc == -1)
{ /* The re-entered one did not match and the user did not
hit cancel. */
@@ -228,10 +228,10 @@ agent_protect_and_store (CTRL ctrl, gcry_sexp_t s_skey)
pi2->check_cb_arg = pi->pin;
next_try:
- rc = agent_askpin (ctrl, text1, initial_errtext, pi);
+ rc = agent_askpin (ctrl, text1, NULL, initial_errtext, pi);
if (!rc)
{
- rc = agent_askpin (ctrl, text2, NULL, pi2);
+ rc = agent_askpin (ctrl, text2, NULL, NULL, pi2);
if (rc == -1)
{ /* The re-entered one did not match and the user did not
hit cancel. */