aboutsummaryrefslogtreecommitdiffstats
path: root/agent/genkey.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2002-08-21 11:11:04 +0000
committerWerner Koch <[email protected]>2002-08-21 11:11:04 +0000
commitcda3b913dbf23cab6829852022584fa510b57fa6 (patch)
treeeb6512398a06e17135e4204674f4c071b54061d0 /agent/genkey.c
parentuse setlocale(). (diff)
downloadgnupg-cda3b913dbf23cab6829852022584fa510b57fa6.tar.gz
gnupg-cda3b913dbf23cab6829852022584fa510b57fa6.zip
* query.c (agent_askpin): Hack to show the right default prompt.NEWPG-0-9-0
(agent_get_passphrase): Ditto. * Makefile.am: Renamed the binary protect-tool to gpg-protect-tool. * protect-tool.c: Removed the note about internal use only. * gpg-agent.c (main): New option --daemon so that the program is not accidently started in the background.
Diffstat (limited to '')
-rw-r--r--agent/genkey.c8
1 files changed, 4 insertions, 4 deletions
diff --git a/agent/genkey.c b/agent/genkey.c
index 630e0e30d..dccac94da 100644
--- a/agent/genkey.c
+++ b/agent/genkey.c
@@ -27,7 +27,7 @@
#include <assert.h>
#include "agent.h"
-
+#include "i18n.h"
static int
store_key (GCRY_SEXP private, const char *passphrase)
@@ -79,7 +79,7 @@ reenter_compare_cb (struct pin_entry_info_s *pi)
if (!strcmp (pin1, pi->pin))
return 0; /* okay */
- pi->cb_errtext = trans ("does not match - try again");
+ pi->cb_errtext = _("does not match - try again");
return -1;
}
@@ -106,9 +106,9 @@ agent_genkey (CTRL ctrl, const char *keyparam, size_t keyparamlen,
/* Get the passphrase now, cause key generation may take a while. */
{
- const char *text1 = trans ("Please enter the passphrase to%0A"
+ const char *text1 = _("Please enter the passphrase to%0A"
"to protect your new key");
- const char *text2 = trans ("Please re-enter this passphrase");
+ const char *text2 = _("Please re-enter this passphrase");
pi = gcry_calloc_secure (2, sizeof (*pi) + 100);
pi2 = pi + (sizeof *pi + 100);