aboutsummaryrefslogtreecommitdiffstats
path: root/agent/command-ssh.c
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2018-01-26 01:08:29 +0000
committerNIIBE Yutaka <[email protected]>2018-01-26 01:13:34 +0000
commit08e686a6a6d5bcb5410228b388745d09686b260c (patch)
treeb91514b92d8e6106e9e5d6b4348ca4280de2c121 /agent/command-ssh.c
parentdoc: Note --quick-gen-key as an alias for --quick-generate-key (diff)
downloadgnupg-08e686a6a6d5bcb5410228b388745d09686b260c.tar.gz
gnupg-08e686a6a6d5bcb5410228b388745d09686b260c.zip
agent: More fix for get_client_pid for portability.
* configure.ac: Check sys/ucred.h instead of ucred.h. * agent/command-ssh.c: Include sys/ucred.h. -- It's *BSD and macOS thing. Fixes-commit: f7f806afa5083617f4aba02fc3b285b06a7d73d4 Signed-off-by: NIIBE Yutaka <[email protected]>
Diffstat (limited to 'agent/command-ssh.c')
-rw-r--r--agent/command-ssh.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/agent/command-ssh.c b/agent/command-ssh.c
index 9d45a1864..213f3f9f7 100644
--- a/agent/command-ssh.c
+++ b/agent/command-ssh.c
@@ -44,8 +44,8 @@
#include <sys/socket.h>
#include <sys/un.h>
#endif /*!HAVE_W32_SYSTEM*/
-#ifdef HAVE_UCRED_H
-#include <ucred.h>
+#ifdef HAVE_SYS_UCRED_H
+#include <sys/ucred.h>
#endif
#include "agent.h"