aboutsummaryrefslogtreecommitdiffstats
path: root/agent/command-ssh.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2005-05-24 12:37:36 +0000
committerWerner Koch <[email protected]>2005-05-24 12:37:36 +0000
commite96af3715b9b126b435c7887e47a660a73bf237b (patch)
tree2cc95e397aa1a3f65016a0b8c15546f430e10060 /agent/command-ssh.c
parent* Makefile.am: Do not build sc-copykeys anymore. (diff)
downloadgnupg-e96af3715b9b126b435c7887e47a660a73bf237b.tar.gz
gnupg-e96af3715b9b126b435c7887e47a660a73bf237b.zip
* call-scd.c (inq_needpin): Skip leading spaces in of PIN
description. * divert-scd.c (getpin_cb): Enhanced to cope with description flags. * query.c (agent_askpin): Add arg PROMPT_TEXT. Changed all callers.
Diffstat (limited to '')
-rw-r--r--agent/command-ssh.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/agent/command-ssh.c b/agent/command-ssh.c
index 92a84c662..030cc70a0 100644
--- a/agent/command-ssh.c
+++ b/agent/command-ssh.c
@@ -2369,7 +2369,7 @@ ssh_identity_register (ctrl_t ctrl, gcry_sexp_t key, int ttl)
}
pi->max_length = 100;
pi->max_tries = 1;
- err = agent_askpin (ctrl, description, NULL, pi);
+ err = agent_askpin (ctrl, description, NULL, NULL, pi);
if (err)
goto out;