aboutsummaryrefslogtreecommitdiffstats
path: root/agent/command-ssh.c
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2018-01-26 01:42:31 +0000
committerNIIBE Yutaka <[email protected]>2018-01-26 01:42:31 +0000
commitd7207b39b71d1b07c4cddac602f29ec583f6d1ad (patch)
tree02f8774e7ed306c782a5f30eb7d477d346d602c4 /agent/command-ssh.c
parentagent: More fix for get_client_pid for portability. (diff)
downloadgnupg-d7207b39b71d1b07c4cddac602f29ec583f6d1ad.tar.gz
gnupg-d7207b39b71d1b07c4cddac602f29ec583f6d1ad.zip
agent: Fix last commit.
* configure.ac: Check ucred.h as well as sys/ucred.h. * agent/command-ssh.c: Add inclusion of ucred.h. -- It was T2981, adding ucred.h for Solaris. We also need sys/ucred.h for FreeBSD and macOS. Signed-off-by: NIIBE Yutaka <[email protected]>
Diffstat (limited to '')
-rw-r--r--agent/command-ssh.c3
1 files changed, 3 insertions, 0 deletions
diff --git a/agent/command-ssh.c b/agent/command-ssh.c
index 213f3f9f7..e0b723839 100644
--- a/agent/command-ssh.c
+++ b/agent/command-ssh.c
@@ -47,6 +47,9 @@
#ifdef HAVE_SYS_UCRED_H
#include <sys/ucred.h>
#endif
+#ifdef HAVE_UCRED_H
+#include <ucred.h>
+#endif
#include "agent.h"