aboutsummaryrefslogtreecommitdiffstats
path: root/agent/call-scd.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2011-12-20 10:12:21 +0000
committerWerner Koch <[email protected]>2011-12-20 10:12:21 +0000
commit366512abe44d9e71bb2c699c29477afa6ac71cdd (patch)
tree5712a4ea7f0b0b24acdd8844d65fb429d04eef35 /agent/call-scd.c
parentAdd error log and debug log for pcsc_keypad_verify and pcsc_keypad_modify. (diff)
downloadgnupg-366512abe44d9e71bb2c699c29477afa6ac71cdd.tar.gz
gnupg-366512abe44d9e71bb2c699c29477afa6ac71cdd.zip
Require Libassuan 2.0.3
* configure.ac: Require Libassuan 2.0.3. * agent/call-scd.c (ASSUAN_CONVEY_COMMENTS): Remove macro replacement. * agent/command.c (cmd_killagent) [ASSUAN_FORCE_CLOSE]: Remove dependency. (cmd_killagent) [ASSUAN_FORCE_CLOSE]: Ditto. * scd/command.c (cmd_killscd) [ASSUAN_FORCE_CLOSE]: Ditto.
Diffstat (limited to 'agent/call-scd.c')
-rw-r--r--agent/call-scd.c9
1 files changed, 0 insertions, 9 deletions
diff --git a/agent/call-scd.c b/agent/call-scd.c
index 3f535db6d..deff2949a 100644
--- a/agent/call-scd.c
+++ b/agent/call-scd.c
@@ -45,15 +45,6 @@
#define MAX_OPEN_FDS 20
#endif
-/* This Assuan flag is only available since libassuan 2.0.2. Because
- comments lines are comments anyway we can use a replacement which
- might not do anything. assuan_{g,s}et_flag don't return an error
- thus there won't be any ABI problem. */
-#ifndef ASSUAN_CONVEY_COMMENTS
-#define ASSUAN_CONVEY_COMMENTS 4
-#endif
-
-
/* Definition of module local data of the CTRL structure. */
struct scd_local_s
{