aboutsummaryrefslogtreecommitdiffstats
path: root/agent/agent.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2002-09-26 07:10:56 +0000
committerWerner Koch <[email protected]>2002-09-26 07:10:56 +0000
commit2d432afff653239ef73c97fdecfff2df1622c62d (patch)
tree3a79b85af1e07965da9043f43dc7e23c39187988 /agent/agent.h
parent* Makefile.am: Link gpg with EGDLIBS (i.e. NETLIBS) as EGD uses sockets. (diff)
downloadgnupg-2d432afff653239ef73c97fdecfff2df1622c62d.tar.gz
gnupg-2d432afff653239ef73c97fdecfff2df1622c62d.zip
* gpg-agent.c (handle_signal): Flush cache on SIGHUP.
* cache.c (agent_flush_cache): New. * gpg-agent.c, agent.h: Add --keep-display and --keep-tty. * query.c (start_pinentry): Implement them. The option passing needs more thoughts.
Diffstat (limited to 'agent/agent.h')
-rw-r--r--agent/agent.h4
1 files changed, 3 insertions, 1 deletions
diff --git a/agent/agent.h b/agent/agent.h
index 51ab19800..24267b06a 100644
--- a/agent/agent.h
+++ b/agent/agent.h
@@ -48,7 +48,8 @@ struct {
int running_detached; /* we are running detached from the tty. */
int ignore_cache_for_signing;
-
+ int keep_tty; /* don't switch the TTY (for pinentry) on request */
+ int keep_display; /* don't switch the DISPLAY (for pinentry) on request */
} opt;
@@ -126,6 +127,7 @@ int agent_get_confirmation (const char *desc, const char *ok,
const char *cancel);
/*-- cache.c --*/
+void agent_flush_cache (void);
int agent_put_cache (const char *key, const char *data, int ttl);
const char *agent_get_cache (const char *key, void **cache_id);
void agent_unlock_cache_entry (void **cache_id);