aboutsummaryrefslogtreecommitdiffstats
path: root/agent/agent.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2014-10-03 09:58:58 +0000
committerWerner Koch <[email protected]>2014-10-03 09:58:58 +0000
commit9c380384dafb213334f8834178c5ceb0bf33db6e (patch)
tree3522eab22d31542094d95c605394542a857e1c55 /agent/agent.h
parentgpg: Fix regression removing SHA256. (diff)
downloadgnupg-9c380384dafb213334f8834178c5ceb0bf33db6e.tar.gz
gnupg-9c380384dafb213334f8834178c5ceb0bf33db6e.zip
Remove support for the GPG_AGENT_INFO envvar.
* agent/agent.h (opt): Remove field use_standard_socket. * agent/command.c (cmd_killagent): Always allow killing. * agent/gpg-agent.c (main): Turn --{no,}use-standard-socket and --write-env-file into dummy options. Always return true for --use-standard-socket-p. Do not print the GPG_AGENT_INFO envvar setting or set that envvar. (create_socket_name): Simplify by removing non standard socket support. (check_for_running_agent): Ditto. * common/asshelp.c (start_new_gpg_agent): Remove GPG_AGENT_INFO use. * common/simple-pwquery.c (agent_open): Ditto. * configure.ac (GPG_AGENT_INFO_NAME): Remove. * g10/server.c (gpg_server): Do not print the AgentInfo comment. * g13/server.c (g13_server): Ditto. * sm/server.c (gpgsm_server): Ditto. * tools/gpgconf.c (main): Simplify by removing non standard socket support. -- The indented fix to allow using a different socket than the one in the gnupg home directory is to change Libassuan to check whether the socket files exists as a regualr file with a special keyword to redirect to another socket file name.
Diffstat (limited to '')
-rw-r--r--agent/agent.h3
1 files changed, 0 insertions, 3 deletions
diff --git a/agent/agent.h b/agent/agent.h
index a420baed9..7342475e7 100644
--- a/agent/agent.h
+++ b/agent/agent.h
@@ -58,9 +58,6 @@ struct
int batch; /* Batch mode */
const char *homedir; /* Configuration directory name */
- /* True if we are listening on the standard socket. */
- int use_standard_socket;
-
/* True if we handle sigusr2. */
int sigusr2_enabled;