aboutsummaryrefslogtreecommitdiffstats
path: root/agent/agent.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2002-06-27 07:29:29 +0000
committerWerner Koch <[email protected]>2002-06-27 07:29:29 +0000
commit56b049686fccd110a368352ac704a9f0eeed67a8 (patch)
treed01226c73876fa4fe966653e982b65d4ede84046 /agent/agent.h
parent* import.c (gpgsm_import): Print an STATUS_IMPORTED. (diff)
downloadgnupg-56b049686fccd110a368352ac704a9f0eeed67a8.tar.gz
gnupg-56b049686fccd110a368352ac704a9f0eeed67a8.zip
* Makefile.am (pkglib_PROGRAMS): Put protect-tool there.
* findkey.c (agent_write_private_key,agent_key_from_file) (agent_key_available): Use GNUPG_PRIVATE_KEYS_DIR constant. * gpg-agent.c (main): Use GNUPG_DEFAULT_HOMEDIR constant. * protect-tool.c (store_private_key): New. (import_p12_file): Store the new file if requested. (main): New options --force and --store. * gpg-agent.c (main): Set a global flag when runing detached. * query.c (start_pinentry): Pass the list of FD to keep in the child when not running detached. * call-scd.c (start_scd): Ditto.
Diffstat (limited to '')
-rw-r--r--agent/agent.h2
1 files changed, 2 insertions, 0 deletions
diff --git a/agent/agent.h b/agent/agent.h
index 75683a0ad..ba6934366 100644
--- a/agent/agent.h
+++ b/agent/agent.h
@@ -45,6 +45,8 @@ struct {
int no_grab; /* don't let the pinentry grab the keyboard */
unsigned long def_cache_ttl;
+ int running_detached; /* we are running detached from the tty. */
+
} opt;