aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-12-24 19:43:16 +0000
committerDavid Shaw <[email protected]>2004-12-24 19:43:16 +0000
commitf5b59b119fa123773274c60dee0f965fd6ae4236 (patch)
tree9bee09e8f5ec2a9cf3f1841f38d2ebe987006715
parent* libcurl.m4: Rewrite this to use the new --protocols flag I gave to the (diff)
downloadgnupg-f5b59b119fa123773274c60dee0f965fd6ae4236.tar.gz
gnupg-f5b59b119fa123773274c60dee0f965fd6ae4236.zip
* configure.ac: Use new LIBCURL_CHECK_CONFIG macro for all libcurl stuff.
This simplifies, and we don't need the automake conditional stuff any longer.
-rw-r--r--ChangeLog6
-rw-r--r--configure.ac31
2 files changed, 23 insertions, 14 deletions
diff --git a/ChangeLog b/ChangeLog
index bfee9c79b..73179c58a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2004-12-24 David Shaw <[email protected]>
+
+ * configure.ac: Use new LIBCURL_CHECK_CONFIG macro for
+ all libcurl stuff. This simplifies, and we don't need the
+ automake conditional stuff any longer.
+
2004-12-22 David Shaw <[email protected]>
* configure.ac: --enable-ftp is on by default, --with-libcurl is
diff --git a/configure.ac b/configure.ac
index 5063c4b31..6b2f5bd9c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -524,19 +524,10 @@ if test x"$try_hkp" = xyes ; then
AC_SUBST(GPGKEYS_HKP,"gpgkeys_hkp$EXEEXT")
fi
-if test x"$try_http" = xyes ; then
- AC_SUBST(GPGKEYS_HTTP,"gpgkeys_http$EXEEXT")
- AC_DEFINE(HTTP_SUPPORT,1,[Define to include HTTP support])
-fi
-
if test x"$try_finger" = xyes ; then
AC_SUBST(GPGKEYS_FINGER,"gpgkeys_finger$EXEEXT")
fi
-if test x"$try_ftp" = xyes ; then
- AC_DEFINE(FTP_SUPPORT,1,[Define to include FTP support])
-fi
-
dnl Must check for network library requirements before doing link tests
dnl for ldap, for example. If ldap libs are static (or dynamic and without
dnl ELF runtime link paths), then link will fail and LDAP support won't
@@ -653,16 +644,28 @@ AC_SUBST(GPGKEYS_LDAP)
AC_SUBST(LDAPLIBS)
AM_CONDITIONAL(GPGKEYS_LDAP, test "$GPGKEYS_LDAP" != "")
-dnl If we have neither FTP or HTTP defined, then don't bother to check
-dnl for curl.
+# If we have neither FTP or HTTP defined, then don't bother to check
+# for curl.
if test "$try_ftp" = yes || test "$try_http" = yes ; then
- GNUPG_CHECK_LIBCURL
+ LIBCURL_CHECK_CONFIG([no],,[have_libcurl=yes])
+fi
+
+# Are we doing HTTP?
+
+if test x"$try_http" = xyes ; then
+ if test x$libcurl_protocol_HTTP = xyes ; then
+ AC_SUBST(GPGKEYS_CURL,"gpgkeys_curl$EXEEXT")
+ AC_DEFINE(HTTP_VIA_LIBCURL,1,[Define if HTTP is handled via libcurl])
+ else
+ AC_SUBST(GPGKEYS_HTTP,"gpgkeys_http$EXEEXT")
+ fi
fi
-AM_CONDITIONAL(HAVE_LIBCURL, test "$have_libcurl" = "yes")
+# Are we doing FTP? We only do FTP if we have libcurl.
-if test x"$have_libcurl" = xyes ; then
+if test x"$try_ftp" = xyes && test x$libcurl_protocol_FTP = xyes ; then
+ AC_DEFINE(FTP_VIA_LIBCURL,1,[Define if FTP is handled via libcurl])
AC_SUBST(GPGKEYS_CURL,"gpgkeys_curl$EXEEXT")
fi