aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Kibbey <[email protected]>2016-09-10 17:42:09 +0000
committerBen Kibbey <[email protected]>2016-09-10 17:42:09 +0000
commiteddcba038025cdbd58aaf67cafd6d83f0ea042d5 (patch)
tree7f7ca834a05be62209c766864617eaea55ae7752
parentFix symbol conflict. (diff)
downloadgnupg-eddcba038025cdbd58aaf67cafd6d83f0ea042d5.tar.gz
gnupg-eddcba038025cdbd58aaf67cafd6d83f0ea042d5.zip
Portability build fix.
* kbx/Makefile.am: Add NETLIBS. * dirmngr/Makefile.am: Ditto for dirmngr_ldap. -- Fixes OpenIndiana (Solaris) builds. Signed-off-by: Ben Kibbey <[email protected]>
-rw-r--r--dirmngr/Makefile.am2
-rw-r--r--kbx/Makefile.am3
2 files changed, 3 insertions, 2 deletions
diff --git a/dirmngr/Makefile.am b/dirmngr/Makefile.am
index 6b0a1e1b7..b7bc21d4a 100644
--- a/dirmngr/Makefile.am
+++ b/dirmngr/Makefile.am
@@ -95,7 +95,7 @@ dirmngr_ldap_CFLAGS = $(GPG_ERROR_CFLAGS) $(LIBGCRYPT_CFLAGS)
dirmngr_ldap_LDFLAGS =
dirmngr_ldap_LDADD = $(libcommon) no-libgcrypt.o \
$(GPG_ERROR_LIBS) $(LIBGCRYPT_LIBS) $(LDAPLIBS) \
- $(LBER_LIBS) $(LIBINTL) $(LIBICONV)
+ $(LBER_LIBS) $(LIBINTL) $(LIBICONV) $(NETLIBS)
endif
dirmngr_client_SOURCES = dirmngr-client.c
diff --git a/kbx/Makefile.am b/kbx/Makefile.am
index 95138e043..912dd7656 100644
--- a/kbx/Makefile.am
+++ b/kbx/Makefile.am
@@ -61,6 +61,7 @@ kbxutil_SOURCES = kbxutil.c $(common_sources)
kbxutil_CFLAGS = $(AM_CFLAGS) -DKEYBOX_WITH_X509=1
kbxutil_LDADD = ../common/libcommon.a \
$(KSBA_LIBS) $(LIBGCRYPT_LIBS) $(extra_libs) \
- $(GPG_ERROR_LIBS) $(LIBINTL) $(LIBICONV) $(W32SOCKLIBS)
+ $(GPG_ERROR_LIBS) $(LIBINTL) $(LIBICONV) $(W32SOCKLIBS) \
+ $(NETLIBS)
$(PROGRAMS) : ../common/libcommon.a