aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-02-12 09:28:52 +0000
committerWerner Koch <[email protected]>2004-02-12 09:28:52 +0000
commite99475d59e214954ca76d07577a1c3e972d4aeac (patch)
treeb78e1a7a346adaefcb94465b41bdb1948a6cc164
parentminor cleanups (diff)
downloadgnupg-e99475d59e214954ca76d07577a1c3e972d4aeac.tar.gz
gnupg-e99475d59e214954ca76d07577a1c3e972d4aeac.zip
* gpgv.c: Removed g10defs.h.
* Makefile.am: Include cmacros.am for common flags.
-rw-r--r--g10/ChangeLog12
-rw-r--r--g10/Makefile.am17
-rw-r--r--g10/g10.c2
-rw-r--r--g10/gpgv.c3
-rw-r--r--g10/openfile.c2
5 files changed, 23 insertions, 13 deletions
diff --git a/g10/ChangeLog b/g10/ChangeLog
index cc4509433..d45fa74ad 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,3 +1,15 @@
+2004-02-12 Werner Koch <[email protected]>
+
+ * gpgv.c: Removed g10defs.h.
+
+ * Makefile.am: Include cmacros.am for common flags.
+
+2004-02-11 Werner Koch <[email protected]>
+
+ * openfile.c (try_make_homedir): Use GNUPG_DEFAULT_HOMEDIR.
+ * gpgv.c (main): Ditto.
+ * g10.c (main): Ditto.
+
2004-01-19 Moritz Schulte <[email protected]>
* keygen.c (do_generate_keypair): Print member fname, instead of
diff --git a/g10/Makefile.am b/g10/Makefile.am
index 00a49df1e..fc33acf73 100644
--- a/g10/Makefile.am
+++ b/g10/Makefile.am
@@ -19,16 +19,15 @@
## Process this file with automake to produce Makefile.in
-localedir = $(datadir)/locale
-INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/include -I$(top_srcdir)/intl -DLOCALEDIR=\"$(localedir)\" @LIBGCRYPT_CFLAGS@
-
EXTRA_DIST = options.skel
-# it seems that we can't use this with automake 1.5
-#OMIT_DEPENDENCIES = zlib.h zconf.h
-libexecdir = @libexecdir@/@PACKAGE@
-if ! HAVE_DOSISH_SYSTEM
-AM_CFLAGS = -DGNUPG_LIBEXECDIR="\"$(libexecdir)\""
-endif
+
+AM_CPPFLAGS = -I$(top_srcdir)/common -I$(top_srcdir)/include \
+ -I$(top_srcdir)/intl
+
+include $(top_srcdir)/am/cmacros.am
+
+AM_CFLAGS = $(LIBGCRYPT_CFLAGS)
+
needed_libs = ../common/libcommon.a ../jnlib/libjnlib.a
bin_PROGRAMS = gpg2 gpgv2
diff --git a/g10/g10.c b/g10/g10.c
index 77e6f6cf9..e3c621453 100644
--- a/g10/g10.c
+++ b/g10/g10.c
@@ -1238,7 +1238,7 @@ main( int argc, char **argv )
set_homedir ( getenv("GNUPGHOME") );
#endif
if( !*opt.homedir )
- set_homedir ( GNUPG_HOMEDIR );
+ set_homedir ( GNUPG_DEFAULT_HOMEDIR );
/* check whether we have a config file on the commandline */
orig_argc = argc;
diff --git a/g10/gpgv.c b/g10/gpgv.c
index 596b09fcb..d020bda62 100644
--- a/g10/gpgv.c
+++ b/g10/gpgv.c
@@ -46,7 +46,6 @@
#include "ttyio.h"
#include "i18n.h"
#include "status.h"
-#include "g10defs.h"
enum cmd_and_opt_values { aNull = 0,
@@ -163,7 +162,7 @@ main( int argc, char **argv )
opt.homedir = getenv("GNUPGHOME");
#endif
if( !opt.homedir || !*opt.homedir ) {
- opt.homedir = GNUPG_HOMEDIR;
+ opt.homedir = GNUPG_DEFAULT_HOMEDIR;
}
tty_no_terminal(1);
tty_batchmode(1);
diff --git a/g10/openfile.c b/g10/openfile.c
index b36e0d8e0..7dbbf7d6a 100644
--- a/g10/openfile.c
+++ b/g10/openfile.c
@@ -360,7 +360,7 @@ copy_options_file( const char *destdir )
void
try_make_homedir( const char *fname )
{
- const char *defhome = GNUPG_HOMEDIR;
+ const char *defhome = GNUPG_DEFAULT_HOMEDIR;
/* Create the directory only if the supplied directory name
* is the same as the default one. This way we avoid to create