aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-09-15 18:33:13 +0000
committerDavid Shaw <[email protected]>2004-09-15 18:33:13 +0000
commite991fb59d151e8512f399c3acf418bca919376f6 (patch)
tree4adfd84bf363f268483ae14d64a95dabcf4d977c
parent* g10.c [HAVE_LIBUSB]: New option --debug-ccid-driver. (diff)
downloadgnupg-e991fb59d151e8512f399c3acf418bca919376f6.tar.gz
gnupg-e991fb59d151e8512f399c3acf418bca919376f6.zip
* configure.ac: Give warning when using capabilities. Check for
usb_get_string_simple for old libusb reasons.
-rw-r--r--ChangeLog5
-rw-r--r--NEWS8
-rw-r--r--configure.ac7
3 files changed, 17 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 43052d9b4..2f743a3ee 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2004-09-15 David Shaw <[email protected]>
+
+ * configure.ac: Give warning when using capabilities. Check for
+ usb_get_string_simple for old libusb reasons.
+
2004-09-10 David Shaw <[email protected]>
* NEWS: Note HTTP basic auth.
diff --git a/NEWS b/NEWS
index 500be593c..db07c2469 100644
--- a/NEWS
+++ b/NEWS
@@ -10,7 +10,8 @@ Noteworthy changes in version 1.3.7
for smartcards.
* HTTP Basic authentication is now supported for all HKP and HTTP
- keyserver functions, either through a proxy or by direct access.
+ keyserver functions, either through a proxy or via direct
+ access.
Noteworthy changes in version 1.3.6 (2004-05-22)
@@ -72,8 +73,9 @@ Noteworthy changes in version 1.3.5 (2004-02-26)
* New --list-config command for frontends and other programs that
call GnuPG. See doc/DETAILS for the specifics of this.
- * Some performance improvements with large keyrings. See
- --enable-key-cache=SIZE in the README file for details.
+ * Some performance improvements with large keyrings. See the
+ build time option --enable-key-cache=SIZE in the README file for
+ details.
* Some portability fixes for the OpenBSD/i386, HPPA, and AIX
platforms.
diff --git a/configure.ac b/configure.ac
index 5993734ec..eb4b9192e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -829,6 +829,12 @@ dnl
dnl Check whether we can use Linux capabilities as requested
dnl
if test "$use_capabilities" = "yes" ; then
+
+AC_MSG_WARN([[
+***
+*** WARNING: using capabilities with GnuPG is experimental code!
+***]])
+
use_capabilities=no
AC_CHECK_HEADERS(sys/capability.h)
if test "$ac_cv_header_sys_capability_h" = "yes" ; then
@@ -1093,6 +1099,7 @@ fi
AC_SUBST(LIBUSB_LIBS)
AC_CHECK_FUNCS(usb_create_match)
AC_CHECK_FUNCS(usb_get_busses)
+AC_CHECK_FUNCS(usb_get_string_simple)
#
# Check for readline support