aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-02-20 15:04:56 +0000
committerDavid Shaw <[email protected]>2004-02-20 15:04:56 +0000
commite867829de79eca53e23c66d753f8f53d20a8993f (patch)
treee890ed6d7db37856eaab15590ce0c64a7e373f08
parent* gpgkeys_ldap.c: Replacement prototypes for setenv and unsetenv. (diff)
downloadgnupg-e867829de79eca53e23c66d753f8f53d20a8993f.tar.gz
gnupg-e867829de79eca53e23c66d753f8f53d20a8993f.zip
* mkdtemp.c: Removed.
* Makefile.am: We get mkdtemp.c from libutil.a now, so don't link with @LIBOBJS@. * keyserver.c (keyserver_spawn): Pass the scheme to the keyserver helper.
-rw-r--r--g10/ChangeLog10
-rw-r--r--g10/Makefile.am3
-rw-r--r--g10/keyserver.c3
-rw-r--r--g10/mkdtemp.c98
4 files changed, 13 insertions, 101 deletions
diff --git a/g10/ChangeLog b/g10/ChangeLog
index b5dbbec14..71e006ccb 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,3 +1,13 @@
+2004-02-20 David Shaw <[email protected]>
+
+ * mkdtemp.c: Removed.
+
+ * Makefile.am: We get mkdtemp.c from libutil.a now, so don't link
+ with @LIBOBJS@.
+
+ * keyserver.c (keyserver_spawn): Pass the scheme to the keyserver
+ helper.
+
2004-02-18 David Shaw <[email protected]>
* options.h, g10.c (main), plaintext.c (handle_plaintext): Add
diff --git a/g10/Makefile.am b/g10/Makefile.am
index 7ec5a8c10..3f08d6204 100644
--- a/g10/Makefile.am
+++ b/g10/Makefile.am
@@ -132,8 +132,7 @@ gpgv_SOURCES = gpgv.c \
# $(common_source)
LDADD = $(needed_libs) @LIBINTL@ @CAPLIBS@ @ZLIBS@ @W32LIBS@
-# gpg gets LIBOBJS to add in mkdtemp if the platform doesn't have it
-gpg_LDADD = @LIBOBJS@ $(LDADD) @DLLIBS@ @NETLIBS@ @LIBUSB_LIBS@
+gpg_LDADD = $(LDADD) @DLLIBS@ @NETLIBS@ @LIBUSB_LIBS@
$(PROGRAMS): $(needed_libs)
diff --git a/g10/keyserver.c b/g10/keyserver.c
index a651f7165..163d3bae0 100644
--- a/g10/keyserver.c
+++ b/g10/keyserver.c
@@ -1,5 +1,5 @@
/* keyserver.c - generic keyserver code
- * Copyright (C) 2001, 2002, 2003 Free Software Foundation, Inc.
+ * Copyright (C) 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
*
* This file is part of GnuPG.
*
@@ -741,6 +741,7 @@ keyserver_spawn(int action,STRLIST list,
fprintf(spawn->tochild,"# This is a gpg keyserver communications file\n");
fprintf(spawn->tochild,"VERSION %d\n",KEYSERVER_PROTO_VERSION);
fprintf(spawn->tochild,"PROGRAM %s\n",VERSION);
+ fprintf(spawn->tochild,"SCHEME %s\n",opt.keyserver_scheme);
if(opt.keyserver_opaque)
fprintf(spawn->tochild,"OPAQUE %s\n",opt.keyserver_opaque);
diff --git a/g10/mkdtemp.c b/g10/mkdtemp.c
deleted file mode 100644
index 3abdc1da6..000000000
--- a/g10/mkdtemp.c
+++ /dev/null
@@ -1,98 +0,0 @@
-/* mkdtemp.c - libc replacement function
- * Copyright (C) 2001 Free Software Foundation, Inc.
- *
- * This file is part of GnuPG.
- *
- * GnuPG is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * GnuPG is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-/* This is a replacement function for mkdtemp in case the platform
- we're building on (like mine!) doesn't have it. */
-
-#include <config.h>
-#include <string.h>
-#include <errno.h>
-#include <sys/stat.h>
-#include <sys/types.h>
-#include <fcntl.h>
-#include <unistd.h>
-#include "types.h"
-#include "cipher.h"
-
-#ifdef MKDIR_TAKES_ONE_ARG
-# undef mkdir
-# define mkdir(a,b) mkdir(a)
-#endif
-
-char *mkdtemp(char *template)
-{
- unsigned int attempts,idx,count=0;
- byte *ch;
-
- idx=strlen(template);
-
- /* Walk backwards to count all the Xes */
- while(idx>0 && template[idx-1]=='X')
- {
- count++;
- idx--;
- }
-
- if(count==0)
- {
- errno=EINVAL;
- return NULL;
- }
-
- ch=&template[idx];
-
- /* Try 4 times to make the temp directory */
- for(attempts=0;attempts<4;attempts++)
- {
- unsigned int remaining=count;
- char *marker=ch;
- byte *randombits;
-
- idx=0;
-
- /* Using really random bits is probably overkill here. The
- worst thing that can happen with a directory name collision
- is that the function will return an error. */
-
- randombits=get_random_bits(4*remaining,0,0);
-
- while(remaining>1)
- {
- sprintf(marker,"%02X",randombits[idx++]);
- marker+=2;
- remaining-=2;
- }
-
- /* Any leftover Xes? get_random_bits rounds up to full bytes,
- so this is safe. */
- if(remaining>0)
- sprintf(marker,"%X",randombits[idx]&0xF);
-
- m_free(randombits);
-
- if(mkdir(template,0700)==0)
- break;
- }
-
- if(attempts==4)
- return NULL; /* keeps the errno from mkdir, whatever it is */
-
- return template;
-}