aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeal H. Walfield <[email protected]>2017-02-02 13:43:15 +0000
committerNeal H. Walfield <[email protected]>2017-02-02 13:43:15 +0000
commite596b21f4b78dd27489e677699cc4ba648051b3f (patch)
tree7731bf71a8a8dd41c5f90a92e7ee39e507fea2da
parentgpg: Ensure TOFU bindings associated with UTKs are registered as usual (diff)
downloadgnupg-e596b21f4b78dd27489e677699cc4ba648051b3f.tar.gz
gnupg-e596b21f4b78dd27489e677699cc4ba648051b3f.zip
Revert "Revert "tests: Add test demonstrating issue2929.""
This reverts commit 59048b0f1aa77313573a1004cd3a9f02692a7521.
-rw-r--r--tests/openpgp/Makefile.am3
-rw-r--r--tests/openpgp/issue2929.scm32
2 files changed, 34 insertions, 1 deletions
diff --git a/tests/openpgp/Makefile.am b/tests/openpgp/Makefile.am
index d1dd44914..5cab3d55d 100644
--- a/tests/openpgp/Makefile.am
+++ b/tests/openpgp/Makefile.am
@@ -96,7 +96,8 @@ XTESTS = \
issue2015.scm \
issue2346.scm \
issue2417.scm \
- issue2419.scm
+ issue2419.scm \
+ issue2929.scm
# XXX: Currently, one cannot override automake's 'check' target. As a
# workaround, we avoid defining 'TESTS', thus automake will not emit
diff --git a/tests/openpgp/issue2929.scm b/tests/openpgp/issue2929.scm
new file mode 100644
index 000000000..44521bb2f
--- /dev/null
+++ b/tests/openpgp/issue2929.scm
@@ -0,0 +1,32 @@
+#!/usr/bin/env gpgscm
+
+;; Copyright (C) 2017 g10 Code GmbH
+;;
+;; This file is part of GnuPG.
+;;
+;; GnuPG is free software; you can redistribute it and/or modify
+;; it under the terms of the GNU General Public License as published by
+;; the Free Software Foundation; either version 3 of the License, or
+;; (at your option) any later version.
+;;
+;; GnuPG is distributed in the hope that it will be useful,
+;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;; GNU General Public License for more details.
+;;
+;; You should have received a copy of the GNU General Public License
+;; along with this program; if not, see <http://www.gnu.org/licenses/>.
+
+(load (with-path "defs.scm"))
+(setup-environment)
+
+(catch (skip "Tofu not supported")
+ (call-check `(,@gpg --trust-model=tofu --list-config)))
+
+;; Redefine GPG without --always-trust and TOFU trust model.
+(define gpg `(,(tool 'gpg) --no-permission-warning --trust-model=tofu))
+
+(info "Checking key creation with TOFU trust model (issue2929).")
+(call-check `(,@gpg --quick-generate-key [email protected]))
+(call-check `(,@gpg --sign gpg.conf))
+(call-check `(,@gpg --verify gpg.conf.gpg))