aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-03-17 23:14:47 +0000
committerDavid Shaw <[email protected]>2005-03-17 23:14:47 +0000
commite19aa2e3ea89ee431cc180387f2a224c8e617c8c (patch)
tree575257dc40f788fdc31bd3f6856875d7f8fd90c4
parent* options.h, keyserver.c (parse_keyserver_options, keyserver_spawn): Don't (diff)
downloadgnupg-e19aa2e3ea89ee431cc180387f2a224c8e617c8c.tar.gz
gnupg-e19aa2e3ea89ee431cc180387f2a224c8e617c8c.zip
* Makefile.am: Calculate GNUPG_LIBEXECDIR directly. Do not redefine
$libexecdir.
-rw-r--r--g10/ChangeLog3
-rw-r--r--g10/Makefile.am16
2 files changed, 7 insertions, 12 deletions
diff --git a/g10/ChangeLog b/g10/ChangeLog
index c95d6c367..6e71ade07 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,5 +1,8 @@
2005-03-17 David Shaw <[email protected]>
+ * Makefile.am: Calculate GNUPG_LIBEXECDIR directly. Do not
+ redefine $libexecdir.
+
* options.h, keyserver.c (parse_keyserver_options,
keyserver_spawn): Don't treat 'verbose' and 'include-disabled' as
special. Just pass them through silently to the keyserver helper.
diff --git a/g10/Makefile.am b/g10/Makefile.am
index 1c0551ca9..2c8bc9a0f 100644
--- a/g10/Makefile.am
+++ b/g10/Makefile.am
@@ -1,5 +1,5 @@
-# Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003,
-# 2004 Free Software Foundation, Inc.
+# Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003, 2004,
+# 2005 Free Software Foundation, Inc.
#
# This file is part of GnuPG.
#
@@ -23,14 +23,13 @@ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/intl
EXTRA_DIST = options.skel
# it seems that we can't use this with automake 1.5
#OMIT_DEPENDENCIES = zlib.h zconf.h
-libexecdir = @libexecdir@/@PACKAGE@
+
if ! HAVE_DOSISH_SYSTEM
-AM_CFLAGS = -DGNUPG_LIBEXECDIR="\"$(libexecdir)\""
+AM_CFLAGS = -DGNUPG_LIBEXECDIR="\"$(libexecdir)/@PACKAGE@\""
endif
needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
other_libs = $(LIBICONV) $(LIBINTL) $(CAPLIBS)
-#noinst_PROGRAMS = gpgd
bin_PROGRAMS = gpg gpgv
if ENABLE_BZIP2_SUPPORT
@@ -125,13 +124,6 @@ gpgv_SOURCES = gpgv.c \
$(common_source) \
verify.c
-#gpgd_SOURCES = gpgd.c \
-# ks-proto.h \
-# ks-proto.c \
-# ks-db.c \
-# ks-db.h \
-# $(common_source)
-
LDADD = $(needed_libs) $(other_libs) @ZLIBS@ @W32LIBS@ @LIBREADLINE@
gpg_LDADD = $(LDADD) @DLLIBS@ @NETLIBS@ @LIBUSB@