aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2002-08-07 14:32:07 +0000
committerDavid Shaw <[email protected]>2002-08-07 14:32:07 +0000
commitdf50c106f84ba72fd48c7be97b9b0e8791744daf (patch)
treec9e2d863771c45c3410bfe38ed2cd31a53c66f47
parentNew Assuan testing tool. (diff)
downloadgnupg-df50c106f84ba72fd48c7be97b9b0e8791744daf.tar.gz
gnupg-df50c106f84ba72fd48c7be97b9b0e8791744daf.zip
* configure.ac: If the static IDEA cipher is present, disable dynamic
loading. Also fix backwards grammar of keyserver exec-path CHECKING message.
-rw-r--r--ChangeLog6
-rw-r--r--configure.ac49
2 files changed, 33 insertions, 22 deletions
diff --git a/ChangeLog b/ChangeLog
index b014a6350..04811374d 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2002-08-07 David Shaw <[email protected]>
+
+ * configure.ac: If the static IDEA cipher is present, disable
+ dynamic loading. Also fix backwards grammar of keyserver
+ exec-path CHECKING message.
+
2002-08-05 Werner Koch <[email protected]>
* configure.ac: Bumbed version number.
diff --git a/configure.ac b/configure.ac
index 9330b4b1b..3b7a4b959 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,11 +89,32 @@ dnl
dnl Check other options
dnl
-AC_MSG_CHECKING([whether use of extensions is requested])
-AC_ARG_ENABLE(dynload,
-[ --disable-dynload disable use of extensions],
- try_dynload=$enableval, try_dynload=yes)
-AC_MSG_RESULT($try_dynload)
+# We don't need idea but some people claim that they need it for
+# research etc., so we allow to place an idea source code into the
+# cipher directory and statically link it if available, otherwise we
+# link to a stub. We don't use AC_CHECK_FILE to avoid caching.
+AC_MSG_CHECKING(for extra cipher modules)
+tmp=""
+if test -f $srcdir/cipher/idea.c; then
+ IDEA_O=idea.o
+ tmp=idea
+else
+ IDEA_O=idea-stub.o
+ tmp=no
+fi
+AC_SUBST(IDEA_O)
+AC_MSG_RESULT($tmp)
+
+# if the static idea is present, disable dynload.
+if test "$IDEA_O" = idea-stub.o ; then
+ AC_MSG_CHECKING([whether use of extensions is requested])
+ AC_ARG_ENABLE(dynload,
+ [ --disable-dynload disable use of extensions],
+ try_dynload=$enableval, try_dynload=yes)
+ AC_MSG_RESULT($try_dynload)
+else
+ try_dynload=no
+fi
AC_MSG_CHECKING([whether assembler modules are requested])
AC_ARG_ENABLE(asm,
@@ -177,7 +198,7 @@ if test "$use_exec" = yes ; then
AC_MSG_RESULT($try_mailto)
fi
- AC_MSG_CHECKING([whether to disable keyserver exec-path])
+ AC_MSG_CHECKING([whether keyserver exec-path is enabled])
AC_ARG_ENABLE(keyserver-path,
[ --disable-keyserver-path disable the exec-path option for keyserver helpers],
[if test "$enableval" = no ; then
@@ -666,22 +687,6 @@ case "$static_random_module" in
;;
esac
-# We don't need idea but some people claim that they need it for
-# research etc., so we allow to place an idea source code into the
-# cipher directory and statically link it if available, otherwise we
-# link to a stub. We don't use AC_CHECK_FILE to avoid caching.
-AC_MSG_CHECKING(for extra cipher modules)
-tmp=""
-if test -f $srcdir/cipher/idea.c; then
- IDEA_O=idea.o
- tmp=idea
-else
- IDEA_O=idea-stub.o
-fi
-AC_SUBST(IDEA_O)
-AC_MSG_RESULT($tmp)
-
-
dnl setup assembler stuff
AC_MSG_CHECKING(for mpi assembler functions)
if test -f $srcdir/mpi/config.links ; then