aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2016-06-17 19:16:37 +0000
committerWerner Koch <[email protected]>2016-06-17 19:16:37 +0000
commitce1689ea0720552ac900d7b2c4139caf24452018 (patch)
treeb0dd21e52526ec059261bc04bbdc70a728556fea
parentgpgscm: Silence compiler warnings. (diff)
downloadgnupg-ce1689ea0720552ac900d7b2c4139caf24452018.tar.gz
gnupg-ce1689ea0720552ac900d7b2c4139caf24452018.zip
tests: Make make distcheck work again.
* Makefile.am (tests): Remove test code which would led to doubling calls to for e.g. "make distclean". * tests/Makefile.am: Typo fixes. * tests/gpgscm/Makefile.am (EXTRA_DIST): Fix name of License file. Add repl.scm. (check): Replace by check-local because check is a standard automake target. * tests/openpgp/Makefile.am (TESTS_ENVIRONMENT): Replace gmake0sim by automake generated macro. (EXTRA_DIST): Add defs.scm Signed-off-by: Werner Koch <[email protected]>
-rw-r--r--Makefile.am2
-rw-r--r--tests/Makefile.am8
-rw-r--r--tests/gpgscm/Makefile.am8
-rw-r--r--tests/openpgp/Makefile.am7
4 files changed, 14 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 3612854d7..bf1230226 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -93,7 +93,7 @@ endif
if RUN_TESTS
tests = tests
else
-tests = tests/gpgscm tests/openpgp
+tests =
endif
SUBDIRS = m4 common kbx \
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e49c2832a..ee8f3a425 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -48,12 +48,12 @@ EXTRA_DIST = runtest inittests $(testscripts) ChangeLog-2011 \
samplekeys/cert_g10code_test1.pem \
samplekeys/cert_g10code_theo1.pem
-# We used to run $(testscripts) here but these asschk scripts ares not
-# completely reliable in all enviromnets and thus we better disable
-# them. The tests are anyway way to minimal. We will eventually
+# We used to run $(testscripts) here but these asschk scripts are not
+# completely reliable in all enviroments and thus we better disable
+# them. The tests are anyway way too minimal. We will eventually
# write new tests based on gpg-connect-agent which has a full fledged
# script language and thus makes it far easier to write tests than to
-# use the low--level asschk stuff.
+# use that low-level asschk stuff.
TESTS =
CLEANFILES = inittests.stamp x y y z out err \
diff --git a/tests/gpgscm/Makefile.am b/tests/gpgscm/Makefile.am
index 1fb964781..e57a4bbe4 100644
--- a/tests/gpgscm/Makefile.am
+++ b/tests/gpgscm/Makefile.am
@@ -18,11 +18,12 @@
# along with this program; if not, see <http://www.gnu.org/licenses/>.
EXTRA_DIST = \
- COPYING \
+ LICENSE.TinySCHEME \
Manual.txt \
ffi.scm \
init.scm \
lib.scm \
+ repl.scm \
t-child.scm \
tests.scm
@@ -31,6 +32,8 @@ include $(top_srcdir)/am/cmacros.am
AM_CFLAGS =
+CLEANFILES =
+
bin_PROGRAMS = gpgscm
noinst_PROGRAMS = t-child
@@ -51,7 +54,6 @@ t_child_SOURCES = t-child.c
# important for things like make -j2.
$(PROGRAMS): $(common_libs)
-.PHONY: check
-check: gpgscm$(EXEEXT) t-child$(EXEEXT)
+check-local: gpgscm$(EXEEXT) t-child$(EXEEXT)
EXEEXT=$(EXEEXT) GPGSCM_PATH=$(srcdir) \
./gpgscm$(EXEEXT) $(srcdir)/t-child.scm
diff --git a/tests/openpgp/Makefile.am b/tests/openpgp/Makefile.am
index f1fdad7ef..921619f8f 100644
--- a/tests/openpgp/Makefile.am
+++ b/tests/openpgp/Makefile.am
@@ -37,7 +37,7 @@ fake_pinentry_SOURCES = fake-pinentry.c
TESTS_ENVIRONMENT = GNUPGHOME=$(abs_builddir) GPG_AGENT_INFO= LC_ALL=C \
EXEEXT=$(EXEEXT) \
PATH=../gpgscm:$(PATH) \
- objdir=$(shell readlink -f ../..) \
+ objdir=$(abs_top_builddir) \
GPGSCM_PATH=$(top_srcdir)/tests/gpgscm:$(top_srcdir)/tests/openpgp
if SQLITE3
@@ -142,8 +142,9 @@ sample_keys = samplekeys/ecc-sample-1-pub.asc \
samplekeys/e2e-p256-1-prt.asc \
samplekeys/E657FB607BB4F21C90BB6651BC067AF28BC90111.asc
-EXTRA_DIST = defs.inc pinentry.sh $(TESTS) $(TEST_FILES) ChangeLog-2011 \
- mkdemodirs signdemokey $(priv_keys) $(sample_keys)
+EXTRA_DIST = defs.inc defs.scm pinentry.sh $(TESTS) $(TEST_FILES) \
+ mkdemodirs signdemokey $(priv_keys) $(sample_keys) \
+ ChangeLog-2011
CLEANFILES = prepared.stamp x y yy z out err $(data_files) \
plain-1 plain-2 plain-3 trustdb.gpg *.lock .\#lk* \