aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2008-12-09 12:32:53 +0000
committerWerner Koch <[email protected]>2008-12-09 12:32:53 +0000
commitcb1d5262270184171a2d602cba0f19fb63c6d7a9 (patch)
tree04dcaa3c8e6264d08e8c61a4b5819ff4b07b839c
parentW32 fix (diff)
downloadgnupg-cb1d5262270184171a2d602cba0f19fb63c6d7a9.tar.gz
gnupg-cb1d5262270184171a2d602cba0f19fb63c6d7a9.zip
Minor bug fix.
-rw-r--r--configure.ac4
-rw-r--r--g10/ChangeLog4
-rw-r--r--g10/gpg.c8
3 files changed, 10 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index fa66e6065..ec5361c55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,8 +24,8 @@ min_automake_version="1.10"
# Remember to change the version number immediately *after* a release.
# Set my_issvn to "yes" for non-released code. Remember to run an
# "svn up" and "autogen.sh" right before creating a distribution.
-m4_define([my_version], [2.0.10rc1])
-m4_define([my_issvn], [no])
+m4_define([my_version], [2.0.10])
+m4_define([my_issvn], [yes])
m4_define([svn_revision], m4_esyscmd([printf "%d" $(svn info 2>/dev/null \
| sed -n '/^Revision:/ s/[^0-9]//gp'|head -1)]))
AC_INIT([gnupg],
diff --git a/g10/ChangeLog b/g10/ChangeLog
index 22d239715..979a681be 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,5 +1,9 @@
2008-12-09 Werner Koch <[email protected]>
+ * gpg.c (main) [IS_DEVELOPMENT_VERSION]: Fix strusage use.
+
+2008-12-09 Werner Koch <[email protected]>
+
* keygen.c (proc_parameter_file): Check that key and subkey usages
are allowed.
diff --git a/g10/gpg.c b/g10/gpg.c
index 9af97fb16..4e72b87e6 100644
--- a/g10/gpg.c
+++ b/g10/gpg.c
@@ -2936,15 +2936,15 @@ main (int argc, char **argv)
fprintf(stderr, "%s\n", strusage(15) );
}
#ifdef IS_DEVELOPMENT_VERSION
- if( !opt.batch )
+ if (!opt.batch)
{
const char *s;
- if((s=strusage(20)))
+ if((s=strusage(25)))
log_info("%s\n",s);
- if((s=strusage(21)))
+ if((s=strusage(26)))
log_info("%s\n",s);
- if((s=strusage(22)))
+ if((s=strusage(27)))
log_info("%s\n",s);
}
#endif