diff options
author | David Shaw <[email protected]> | 2003-04-07 21:52:38 +0000 |
---|---|---|
committer | David Shaw <[email protected]> | 2003-04-07 21:52:38 +0000 |
commit | c88bc35372aeb8a1251afc433bf8f60552b84141 (patch) | |
tree | 842974947d6402351bb4b91d0caed0f3b99817bf | |
parent | * pkclist.c (algo_available): PGP 8 can use the SHA-256 hash. (diff) | |
download | gnupg-c88bc35372aeb8a1251afc433bf8f60552b84141.tar.gz gnupg-c88bc35372aeb8a1251afc433bf8f60552b84141.zip |
* configure.ac: Use much more accurate method to determine whether
DNS SRV is usable.
* README: Document the various --disable-xxx switches, and add a note
about existing keys that may use one of the missing ciphers as a
preference. Update copyright date.
* NEWS: Add note about SHA-256/384/512.
* acinclude.m4: Fix URL to faqprog.pl.
-rw-r--r-- | ChangeLog | 13 | ||||
-rw-r--r-- | NEWS | 3 | ||||
-rw-r--r-- | README | 27 | ||||
-rw-r--r-- | acinclude.m4 | 2 | ||||
-rw-r--r-- | configure.ac | 43 |
5 files changed, 56 insertions, 32 deletions
@@ -1,3 +1,16 @@ +2003-04-07 David Shaw <[email protected]> + + * configure.ac: Use much more accurate method to determine whether + DNS SRV is usable. + + * README: Document the various --disable-xxx switches, and add a + note about existing keys that may use one of the missing ciphers + as a preference. Update copyright date. + + * NEWS: Add note about SHA-256/384/512. + + * acinclude.m4: Fix URL to faqprog.pl. + 2003-03-24 Werner Koch <[email protected]> * acinclude.m4 (GNUPG_CHECK_ENDIAN): When crosscompiling assume @@ -50,6 +50,9 @@ Noteworthy changes in version 1.3.2 (unreleased) This is a simpler interface to the old method (which still works) of revoking the user ID self-signature. + * Add read-only support for the SHA-256 hash, and optional + read-only support for the SHA-384 and SHA-512 hashes. + Noteworthy changes in version 1.3.1 (2002-11-12) ------------------------------------------------ @@ -1,9 +1,9 @@ GnuPG - The GNU Privacy Guard ------------------------------- - Version 1.3.2 + Version 1.3.2 - Copyright 1998, 1999, 2000, 2001, 2002 Free Software Foundation, Inc. + Copyright 1998-2003 Free Software Foundation, Inc. This file is free software; as a special exception the author gives unlimited permission to copy and/or distribute it, with or without @@ -523,6 +523,29 @@ disable any ability for the user to change it in their options file. + --disable-idea + --disable-cast5 + --disable-blowfish + --disable-aes + --disable-twofish + --disable-tiger192 + --disable-sha256 + --disable-sha512 + Removes support for the selected algorithm. This + can give a smaller gpg binary for places where + space is tight. + + *** Note, that if there are existing keys that + have one of these algorithms as a preference, + messages may be received that use one of these + algorithms and you will not be able to decrypt the + message! *** + + A public key preference list can be updated to + match the list of available algorithms by using + 'gpg --edit (thekey)', and running the "updpref" + command. + Installation Problems --------------------- diff --git a/acinclude.m4 b/acinclude.m4 index 89cfac06c..83af3c5fb 100644 --- a/acinclude.m4 +++ b/acinclude.m4 @@ -83,7 +83,7 @@ dnl *** dnl *** It seems that the faqprog.pl program is not installed; dnl *** however it is only needed if you want to change the FAQ. dnl *** (faqprog.pl should be available at: -dnl *** ftp://ftp.gnupg.org/pub/gcrypt/contrib/faqprog.pl ) +dnl *** ftp://ftp.gnupg.org/gcrypt/contrib/faqprog.pl ) dnl *** No need to worry about this warning. dnl ***]]) dnl fi diff --git a/configure.ac b/configure.ac index 03edddcae..b967d4b88 100644 --- a/configure.ac +++ b/configure.ac @@ -440,38 +440,23 @@ AC_ARG_ENABLE(dns-srv, use_dns_srv=$enableval,use_dns_srv=yes) if test x"$try_hkp" = xyes && test x"$use_dns_srv" = xyes ; then - AC_CHECK_FUNC(res_query) + _srv_save_libs=$LIBS + LIBS="" # the double underscore thing is a glibc-ism? - if test $ac_cv_func_res_query = no ; then - AC_CHECK_FUNC(__res_query) - ac_cv_func_res_query=$ac_cv_func___res_query - fi - if test $ac_cv_func_res_query = no ; then - AC_CHECK_LIB(resolv,res_query) - ac_cv_func_res_query=$ac_cv_lib_resolv_res_query - srvlib="-lresolv" - fi - if test $ac_cv_func_res_query = no ; then - AC_CHECK_LIB(resolv,__res_query) - ac_cv_func_res_query=$ac_cv_lib_resolv___res_query - srvlib="-lresolv" - fi - if test $ac_cv_func_res_query = no ; then - AC_CHECK_LIB(bind,res_query) - ac_cv_func_res_query=$ac_cv_lib_bind_res_query - srvlib="-lbind" - fi - if test $ac_cv_func_res_query = no ; then - AC_CHECK_LIB(bind,__res_query) - ac_cv_func_res_query=$ac_cv_lib_bind___res_query - srvlib="-lbind" - fi - # we assume if we can find res_query, we can also use the dn_expand - # and dn_skipname functions. - if test x"$ac_cv_func_res_query" = xyes ; then + AC_SEARCH_LIBS(res_query,resolv bind,, + AC_SEARCH_LIBS(__res_query,resolv bind,,use_dns_srv=no)) + AC_SEARCH_LIBS(dn_expand,resolv bind,, + AC_SEARCH_LIBS(__dn_expand,resolv bind,,use_dns_srv=no)) + AC_SEARCH_LIBS(dn_skipname,resolv bind,, + AC_SEARCH_LIBS(__dn_skipname,resolv bind,,use_dns_srv=no)) + + if test x"$use_dns_srv" = xyes ; then AC_DEFINE(USE_DNS_SRV,1,[define to use DNS SRV]) - SRVLIBS=$srvlib + SRVLIBS=$LIBS + else + AC_MSG_WARN([Resolver functions not found. Disabling DNS SRV.]) fi + LIBS=$_srv_save_libs fi AC_SUBST(SRVLIBS) |