aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-10-26 15:56:53 +0000
committerDavid Shaw <[email protected]>2003-10-26 15:56:53 +0000
commitc43bc4f52d5e2856c67023dc6165db15cc0dbb18 (patch)
tree94a5f34b08b3d5df9993fbe9314f0b5bfd7ac535
parent* g10.c (main): Enhance the version-specific config file code to try for (diff)
downloadgnupg-c43bc4f52d5e2856c67023dc6165db15cc0dbb18.tar.gz
gnupg-c43bc4f52d5e2856c67023dc6165db15cc0dbb18.zip
* NEWS: Note --symmetric --encrypt and the improved config file search.
* configure.ac: Add SAFE_VERSION_DOT and SAFE_VERSION_DASH.
-rw-r--r--ChangeLog7
-rw-r--r--NEWS12
-rw-r--r--configure.ac8
3 files changed, 23 insertions, 4 deletions
diff --git a/ChangeLog b/ChangeLog
index f3c15c89f..f11b71aca 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+2003-10-26 David Shaw <[email protected]>
+
+ * NEWS: Note --symmetric --encrypt and the improved config file
+ search.
+
+ * configure.ac: Add SAFE_VERSION_DOT and SAFE_VERSION_DASH.
+
2003-10-25 Werner Koch <[email protected]>
* Makefile.am (SUBDIRS): Add intl.
diff --git a/NEWS b/NEWS
index 8f3b56c5a..b6a98b4be 100644
--- a/NEWS
+++ b/NEWS
@@ -1,13 +1,21 @@
Noteworthy changes in version 1.3.4 (unreleased)
------------------------------------------------
+ * --symmetric --encrypt can now be used to generate a message that
+ can be decrypted by either a passphrase or a secret key.
+
+ * The config file search has been enhanced to try for more
+ specific filename matches before giving up. For example,
+ version 1.3.4 will try for gpg.conf-1.3.4, gpg.conf-1.3, and
+ gpg.conf-1 before falling back to the regular gpg.conf file.
+
Noteworthy changes in version 1.3.3 (2003-10-10)
------------------------------------------------
* Basic support for the OpenPGP card. New commands --card-status,
- card-edit, --change-pin and the configuration options
- --reader-port, --ctapi-driver, --pcsc-driver, --disable-ccid.
+ --card-edit, --change-pin and the configuration options
+ --reader-port, --ctapi-driver, --pcsc-driver, and --disable-ccid.
* Full support for the SHA-256 hash has been added.
diff --git a/configure.ac b/configure.ac
index c8d3229b8..97ae48c33 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1115,8 +1115,12 @@ cat >g10defs.tmp <<G10EOF
#define EXTSEP_S "."
#endif
/* This is the same as VERSION, but should be overridden if the
- platform cannot handle things like dots '.' in filenames. */
-#define SAFE_VERSION VERSION
+ platform cannot handle things like dots'.' in filenames. Set
+ SAFE_VERSION_DOT and SAFE_VERSION_DASH to whatever SAFE_VERSION
+ uses for dots and dashes. */
+#define SAFE_VERSION VERSION
+#define SAFE_VERSION_DOT '.'
+#define SAFE_VERSION_DASH '-'
G10EOF
cat mpi/mpi-asm-defs.h >>g10defs.tmp
if cmp -s g10defs.h g10defs.tmp 2>/dev/null; then