aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-10-15 13:16:58 +0000
committerWerner Koch <[email protected]>2004-10-15 13:16:58 +0000
commitc3a51cd17d3a499b14b6329fd9390fa9d73521b7 (patch)
tree868e5aed3a1ec36f25923543e777af353451d63e
parent* gpgkeys_ldap.c (main, show_help): Kludge to implement standard (diff)
downloadgnupg-c3a51cd17d3a499b14b6329fd9390fa9d73521b7.tar.gz
gnupg-c3a51cd17d3a499b14b6329fd9390fa9d73521b7.zip
* README: Mentioned --enable-selinux-support.
* status.h (STATUS_NEED_PASSPHRASE_PIN): New. * status.c (get_status_string): Added. * passphrase.c (ask_passphrase): Moved status printing to .. * cardglue.c (pin_cb): .. here and issue new status message. * keyedit.c (sign_uids): Don't include the leading LF in the translatable string but print them separately. * apdu.c (apdu_open_remote_reader) [_WIN32]: We don't have ENOSYS.
-rw-r--r--ChangeLog6
-rw-r--r--NEWS2
-rw-r--r--README6
-rw-r--r--configure.ac2
-rw-r--r--doc/DETAILS5
-rw-r--r--g10/ChangeLog10
-rw-r--r--g10/apdu.c8
-rw-r--r--g10/cardglue.c4
-rw-r--r--g10/ccid-driver.c2
-rw-r--r--g10/keyedit.c40
-rw-r--r--g10/passphrase.c3
-rw-r--r--g10/status.c1
-rw-r--r--g10/status.h1
13 files changed, 69 insertions, 21 deletions
diff --git a/ChangeLog b/ChangeLog
index 6752baba2..077f6a293 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2004-10-15 Werner Koch <[email protected]>
+
+ Released 1.3.91.
+
+ * README: Mentioned --enable-selinux-support.
+
2004-10-15 David Shaw <[email protected]>
* NEWS: Note gpgkeys_finger, keyserver timeouts, and the direct
diff --git a/NEWS b/NEWS
index e8c50e202..2e6e00b83 100644
--- a/NEWS
+++ b/NEWS
@@ -1,4 +1,4 @@
-Noteworthy changes in version 1.3.91
+Noteworthy changes in version 1.3.91 (2004-10-15)
-------------------------------------------------
* A new configure option --enable-selinux-support disallows
diff --git a/README b/README
index 9d635e5ab..54357c3bf 100644
--- a/README
+++ b/README
@@ -1,7 +1,7 @@
GnuPG - The GNU Privacy Guard
-------------------------------
- Version 1.3.90
+ Version 1.3.91
Copyright 1998, 1999, 2000, 2001, 2002, 2003,
2004 Free Software Foundation, Inc.
@@ -601,6 +601,10 @@
to include support if all required libraries are
available.
+ --enable-selinux-support
+ This prevents access to certain files and won't
+ allow import or export of secret keys.
+
Installation Problems
---------------------
diff --git a/configure.ac b/configure.ac
index 0e32609ee..ef4b5a602 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,7 @@ min_automake_version="1.7.9"
# Remember to change the version number immediately *after* a release
# and remove the "-cvs" or "rc" suffix immediately *before* a release.
-AC_INIT(gnupg, 1.3.91-cvs, [email protected])
+AC_INIT(gnupg, 1.3.91, [email protected])
# Set development_version to yes if the minor number is odd or you
# feel that the default check for a development version is not
# sufficient.
diff --git a/doc/DETAILS b/doc/DETAILS
index e8b9efd03..688ac0444 100644
--- a/doc/DETAILS
+++ b/doc/DETAILS
@@ -330,6 +330,9 @@ more arguments in future versions.
NEED_PASSPHRASE_SYM <cipher_algo> <s2k_mode> <s2k_hash>
Issued whenever a passphrase for symmetric encryption is needed.
+ NEED_PASSPHRASE_PIN <card_type> <chvno>
+ Issued whenever a PIN is requested to unlock a card.
+
MISSING_PASSPHRASE
No passphrase was supplied. An application which encounters this
message may want to stop parsing immediately because the next message
@@ -535,7 +538,7 @@ more arguments in future versions.
0x02 = this attribute packet is revoked
0x04 = this attribute packet is expired
- STATUSCTRL <what> [<serialno>]
+ CARDCTRL <what> [<serialno>]
This is used to control smartcard operations.
Defined values for WHAT are:
1 = Request insertion of a card. Serialnumber may be given
diff --git a/g10/ChangeLog b/g10/ChangeLog
index 96d1c6929..8f8f40148 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,5 +1,15 @@
2004-10-15 Werner Koch <[email protected]>
+ * status.h (STATUS_NEED_PASSPHRASE_PIN): New.
+ * status.c (get_status_string): Added.
+ * passphrase.c (ask_passphrase): Moved status printing to ..
+ * cardglue.c (pin_cb): .. here and issue new status message.
+
+ * keyedit.c (sign_uids): Don't include the leading LF in the
+ translatable string but print them separately.
+
+ * apdu.c (apdu_open_remote_reader) [_WIN32]: We don't have ENOSYS.
+
* app-openpgp.c (parse_login_data): New.
(app_select_openpgp): Call it.
(do_setattr): Reparse it after change.
diff --git a/g10/apdu.c b/g10/apdu.c
index f2bc2f21d..e58be590d 100644
--- a/g10/apdu.c
+++ b/g10/apdu.c
@@ -16,6 +16,8 @@
* You should have received a copy of the GNU General Public License
* along with this program; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ *
+ * $Id$
*/
#include <config.h>
@@ -2047,9 +2049,11 @@ apdu_open_remote_reader (const char *portstr,
writefnc, writefnc_value,
closefnc, closefnc_value);
#else
- #ifndef _WIN32
+#ifdef _WIN32
+ errno = ENOENT;
+#else
errno = ENOSYS;
- #endif
+#endif
return -1;
#endif
}
diff --git a/g10/cardglue.c b/g10/cardglue.c
index c5b76edcc..64635b450 100644
--- a/g10/cardglue.c
+++ b/g10/cardglue.c
@@ -628,6 +628,10 @@ pin_cb (void *opaque, const char *info, char **retstr)
*retstr = NULL;
log_debug ("asking for PIN '%s'\n", info);
+ if (is_status_enabled())
+ write_status_text (STATUS_NEED_PASSPHRASE_PIN,
+ isadmin? "OPENPGP 3" : "OPENPGP 1");
+
value = ask_passphrase (info,
isadmin? "passphrase.adminpin.ask"
: "passphrase.pin.ask",
diff --git a/g10/ccid-driver.c b/g10/ccid-driver.c
index 287a8d87d..0a876f0bc 100644
--- a/g10/ccid-driver.c
+++ b/g10/ccid-driver.c
@@ -51,6 +51,8 @@
* STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
* ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
* OF THE POSSIBILITY OF SUCH DAMAGE.
+ *
+ * $Id$
*/
diff --git a/g10/keyedit.c b/g10/keyedit.c
index 53fbf5964..0286e9706 100644
--- a/g10/keyedit.c
+++ b/g10/keyedit.c
@@ -921,40 +921,56 @@ sign_uids( KBNODE keyblock, STRLIST locusr, int *ret_modified,
if(selfsig)
{
- tty_printf(_("\nThis will be a self-signature.\n"));
+ tty_printf("\n");
+ tty_printf(_("This will be a self-signature.\n"));
if( local )
- tty_printf(
- _("\nWARNING: the signature will not be marked "
+ {
+ tty_printf("\n");
+ tty_printf(
+ _("WARNING: the signature will not be marked "
"as non-exportable.\n"));
+ }
if( nonrevocable )
- tty_printf(
- _("\nWARNING: the signature will not be marked "
+ {
+ tty_printf("\n");
+ tty_printf(
+ _("WARNING: the signature will not be marked "
"as non-revocable.\n"));
+ }
}
else
{
if( local )
- tty_printf(
- _("\nThe signature will be marked as non-exportable.\n"));
+ {
+ tty_printf("\n");
+ tty_printf(
+ _("The signature will be marked as non-exportable.\n"));
+ }
if( nonrevocable )
- tty_printf(
- _("\nThe signature will be marked as non-revocable.\n"));
+ {
+ tty_printf("\n");
+ tty_printf(
+ _("The signature will be marked as non-revocable.\n"));
+ }
switch(class)
{
case 0x11:
- tty_printf(_("\nI have not checked this key at all.\n"));
+ tty_printf("\n");
+ tty_printf(_("I have not checked this key at all.\n"));
break;
case 0x12:
- tty_printf(_("\nI have checked this key casually.\n"));
+ tty_printf("\n");
+ tty_printf(_("I have checked this key casually.\n"));
break;
case 0x13:
- tty_printf(_("\nI have checked this key very carefully.\n"));
+ tty_printf("\n");
+ tty_printf(_("I have checked this key very carefully.\n"));
break;
}
}
diff --git a/g10/passphrase.c b/g10/passphrase.c
index 37977fcf3..593c85622 100644
--- a/g10/passphrase.c
+++ b/g10/passphrase.c
@@ -1025,9 +1025,6 @@ ask_passphrase (const char *description,
if (canceled)
*canceled = 0;
- if (is_status_enabled())
- write_status_text( STATUS_NEED_PASSPHRASE_SYM, "0 0 0");
-
if (!opt.batch && description)
tty_printf ("\n%s\n",description);
diff --git a/g10/status.c b/g10/status.c
index d0bc08d87..bc06da10d 100644
--- a/g10/status.c
+++ b/g10/status.c
@@ -114,6 +114,7 @@ get_status_string ( int no )
case STATUS_NO_PUBKEY : s = "NO_PUBKEY"; break;
case STATUS_NO_SECKEY : s = "NO_SECKEY"; break;
case STATUS_NEED_PASSPHRASE_SYM: s = "NEED_PASSPHRASE_SYM"; break;
+ case STATUS_NEED_PASSPHRASE_PIN: s = "NEED_PASSPHRASE_PIN"; break;
case STATUS_DECRYPTION_FAILED: s = "DECRYPTION_FAILED"; break;
case STATUS_DECRYPTION_OKAY: s = "DECRYPTION_OKAY"; break;
case STATUS_MISSING_PASSPHRASE: s = "MISSING_PASSPHRASE"; break;
diff --git a/g10/status.h b/g10/status.h
index c6c730bbe..06dca9ac0 100644
--- a/g10/status.h
+++ b/g10/status.h
@@ -104,6 +104,7 @@
#define STATUS_PLAINTEXT 73
#define STATUS_PLAINTEXT_LENGTH 74
#define STATUS_KEY_NOT_CREATED 75
+#define STATUS_NEED_PASSPHRASE_PIN 76
/*-- status.c --*/
void set_status_fd ( int fd );