aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2002-10-24 22:33:22 +0000
committerDavid Shaw <[email protected]>2002-10-24 22:33:22 +0000
commitbe1d2a4038e2bd0dce938993d7f85664a10ca315 (patch)
tree2582196196c48f39d592f8a38b1004a3e6546eee
parent * gpg.sgml: Document --refresh-keys. (diff)
downloadgnupg-be1d2a4038e2bd0dce938993d7f85664a10ca315.tar.gz
gnupg-be1d2a4038e2bd0dce938993d7f85664a10ca315.zip
* gpgkeys_hkp.c (main), gpgkeys_ldap.c (main): Add -V flag to output
protocol and program version.
-rw-r--r--keyserver/ChangeLog5
-rw-r--r--keyserver/gpgkeys_hkp.c7
-rw-r--r--keyserver/gpgkeys_ldap.c7
3 files changed, 17 insertions, 2 deletions
diff --git a/keyserver/ChangeLog b/keyserver/ChangeLog
index 7fe17607d..a32c8944a 100644
--- a/keyserver/ChangeLog
+++ b/keyserver/ChangeLog
@@ -1,3 +1,8 @@
+2002-10-24 David Shaw <[email protected]>
+
+ * gpgkeys_hkp.c (main), gpgkeys_ldap.c (main): Add -V flag to
+ output protocol and program version.
+
2002-10-21 David Shaw <[email protected]>
* Makefile.am: Anything linking with libutil.a needs INTLLIBS as
diff --git a/keyserver/gpgkeys_hkp.c b/keyserver/gpgkeys_hkp.c
index f5a0ed0ca..514205adf 100644
--- a/keyserver/gpgkeys_hkp.c
+++ b/keyserver/gpgkeys_hkp.c
@@ -741,15 +741,20 @@ main(int argc,char *argv[])
console=stderr;
- while((arg=getopt(argc,argv,"ho:"))!=-1)
+ while((arg=getopt(argc,argv,"hVo:"))!=-1)
switch(arg)
{
default:
case 'h':
fprintf(console,"-h\thelp\n");
+ fprintf(console,"-V\tversion\n");
fprintf(console,"-o\toutput to this file\n");
return KEYSERVER_OK;
+ case 'V':
+ fprintf(stdout,"0\n%s\n",VERSION);
+ return KEYSERVER_OK;
+
case 'o':
output=fopen(optarg,"w");
if(output==NULL)
diff --git a/keyserver/gpgkeys_ldap.c b/keyserver/gpgkeys_ldap.c
index ad8f0cf13..21c883005 100644
--- a/keyserver/gpgkeys_ldap.c
+++ b/keyserver/gpgkeys_ldap.c
@@ -720,15 +720,20 @@ main(int argc,char *argv[])
console=stderr;
- while((arg=getopt(argc,argv,"ho:"))!=-1)
+ while((arg=getopt(argc,argv,"hVo:"))!=-1)
switch(arg)
{
default:
case 'h':
fprintf(console,"-h\thelp\n");
+ fprintf(console,"-V\tversion\n");
fprintf(console,"-o\toutput to this file\n");
return KEYSERVER_OK;
+ case 'V':
+ fprintf(stdout,"0\n%s\n",VERSION);
+ return KEYSERVER_OK;
+
case 'o':
output=fopen(optarg,"w");
if(output==NULL)