aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-12-06 20:54:05 +0000
committerDavid Shaw <[email protected]>2005-12-06 20:54:05 +0000
commitbc1c4af8c3ce3ca4ba0ae2b01843553e415dbb51 (patch)
tree582ab2438b8763ab3779f7a98f5d94d41cf4f4b4
parent* idea-stub.c (load_module): Not legal to return a void * as a function (diff)
downloadgnupg-bc1c4af8c3ce3ca4ba0ae2b01843553e415dbb51.tar.gz
gnupg-bc1c4af8c3ce3ca4ba0ae2b01843553e415dbb51.zip
Some cleanup so we don't build files that are completely ifdeffed out.
This causes a warning on Sun's cc. Do the internal regex code as well for consistency.
-rw-r--r--configure.ac13
-rw-r--r--g10/trustdb.c2
-rw-r--r--util/ChangeLog4
-rw-r--r--util/Makefile.am38
4 files changed, 36 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 076e29b6b..f8162dac7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -469,6 +469,8 @@ case "${host}" in
need_dlopen=no
try_gettext="no"
agent_support=no
+ use_simple_gettext=yes
+ have_w32_system=yes
;;
i?86-emx-os2 | i?86-*-os2*emx )
# OS/2 with the EMX environment
@@ -523,6 +525,9 @@ if test "$have_dosish_system" = yes; then
fi
AM_CONDITIONAL(HAVE_DOSISH_SYSTEM, test "$have_dosish_system" = yes)
+AM_CONDITIONAL(USE_SIMPLE_GETTEXT, test x"$use_simple_gettext" = xyes)
+AM_CONDITIONAL(HAVE_W32_SYSTEM, test x"$have_w32_system" = xyes)
+
if test "$disable_keyserver_path" = yes; then
AC_DEFINE(DISABLE_KEYSERVER_PATH,1,
[define to disable exec-path for keyserver helpers])
@@ -786,7 +791,7 @@ AC_CHECK_SIZEOF(unsigned long long)
# Ensure that we have UINT64_C before we bother to check for uint64_t
gt_HEADER_INTTYPES_H
AC_CACHE_CHECK([for UINT64_C], [gnupg_cv_uint64_c_works],
- AC_COMPILE_IFELSE(AC_LANG_PROGRAM([
+ AC_COMPILE_IFELSE(AC_LANG_PROGRAM([#include <inttypes.h>],[
uint64_t foo=UINT64_C(42);]),gnupg_cv_uint64_c_works=yes,gnupg_cv_uint64_c_works=no))
if test "$gnupg_cv_uint64_c_works" = "yes" ; then
@@ -1070,14 +1075,14 @@ main() { regex_t blah ; regmatch_t p; p.rm_eo = p.rm_eo; return regcomp(&blah, "
fi
if test $gnupg_cv_included_regex = yes; then
- AC_DEFINE(USE_GNU_REGEX,1,[ Define if you want to use the included regex lib ])
- AC_SUBST(REGEX_O,regex.o)
+ AC_DEFINE(USE_INTERNAL_REGEX,1,[ Define if you want to use the included regex lib ])
fi
else
-
AC_DEFINE(DISABLE_REGEX,1,[ Define to disable regular expression support ])
fi
+AM_CONDITIONAL(USE_INTERNAL_REGEX, test x"$gnupg_cv_included_regex" = xyes)
+
dnl Do we have zlib? Must do it here because Solaris failed
dnl when compiling a conftest (due to the "-lz" from LIBS).
use_local_zlib=yes
diff --git a/g10/trustdb.c b/g10/trustdb.c
index 7269afc31..bb5167ea9 100644
--- a/g10/trustdb.c
+++ b/g10/trustdb.c
@@ -28,7 +28,7 @@
#ifndef DISABLE_REGEX
#include <sys/types.h>
-#ifdef USE_GNU_REGEX
+#ifdef USE_INTERNAL_REGEX
#include "_regex.h"
#else
#include <regex.h>
diff --git a/util/ChangeLog b/util/ChangeLog
index d69853c44..754b9d277 100644
--- a/util/ChangeLog
+++ b/util/ChangeLog
@@ -1,5 +1,9 @@
2005-12-06 David Shaw <[email protected]>
+ * Makefile.am: Some cleanup so we don't build files that are
+ completely ifdeffed out. This causes a warning on Sun's cc. Do
+ the internal regex code as well for consistency.
+
* mkdtemp.c (mkdtemp): Fix warning.
* secmem.c, assuan-buffer.c, dotlock.c: Fix a few warnings from
diff --git a/util/Makefile.am b/util/Makefile.am
index cb2019be4..8be94a90b 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -22,28 +22,35 @@ INCLUDES = -I.. -I$(top_srcdir)/include -I$(top_srcdir)/intl
noinst_LIBRARIES = libutil.a
-EXTRA_libutil_a_SOURCES = regcomp.c regex.c regexec.c regex_internal.c \
- regex_internal.h
+libutil_a_SOURCES = logger.c fileutil.c miscutil.c strgutil.c \
+ ttyio.c argparse.c memory.c secmem.c errors.c iobuf.c \
+ dotlock.c http.c srv.h srv.c pka.c membuf.c
+
+if USE_SIMPLE_GETTEXT
+libutil_a_SOURCES+=simple-gettext.c
+endif
+
+if HAVE_W32_SYSTEM
+libutil_a_SOURCES+=w32reg.c
+endif
-# We build the assuan support only if it has been requested.
if ENABLE_AGENT_SUPPORT
-assuan_source = assuan-buffer.c assuan-client.c assuan-defs.h \
- assuan-errors.c assuan-logging.c assuan-socket-connect.c \
- assuan-connect.c assuan-socket.c assuan-util.c
-else
-assuan_source =
+libutil_a_SOURCES+=assuan-buffer.c assuan-client.c assuan-defs.h \
+ assuan-errors.c assuan-logging.c assuan-socket-connect.c \
+ assuan-connect.c assuan-socket.c assuan-util.c
endif
+if USE_INTERNAL_REGEX
+libutil_a_SOURCES+=regex.c
+endif
-#libutil_a_LDFLAGS =
-libutil_a_SOURCES = logger.c fileutil.c miscutil.c strgutil.c \
- ttyio.c argparse.c memory.c secmem.c errors.c iobuf.c \
- dotlock.c http.c srv.h srv.c pka.c simple-gettext.c \
- membuf.c w32reg.c $(assuan_source)
+# The internal regex code #includes these.
+EXTRA_libutil_a_SOURCES = regcomp.c regexec.c regex_internal.c \
+ regex_internal.h
-libutil_a_DEPENDENCIES = @LIBOBJS@ @REGEX_O@
# LIBOBJS is for the replacement functions
-libutil_a_LIBADD = @LIBOBJS@ @REGEX_O@
+libutil_a_DEPENDENCIES = @LIBOBJS@
+libutil_a_LIBADD = @LIBOBJS@
http-test: http.c
cc -DHAVE_CONFIG_H -I. -I. -I.. $(INCLUDES) $(LDFLAGS) -g -Wall \
@@ -56,4 +63,3 @@ srv-test: srv.c
pka-test: pka.c
cc -DHAVE_CONFIG_H -I. -I. -I.. $(INCLUDES) $(LDFLAGS) -g -Wall \
-DTEST -o pka-test pka.c libutil.a @LIBINTL@ @SRVLIBS@ @CAPLIBS@
-