diff options
author | David Shaw <[email protected]> | 2002-07-09 02:55:00 +0000 |
---|---|---|
committer | David Shaw <[email protected]> | 2002-07-09 02:55:00 +0000 |
commit | b67d342b9d79717cade1b165effb3683794be935 (patch) | |
tree | 5dc855d1599b6a365f52e3172dd851bc744f324d | |
parent | * argparse.c (initialize): We better exit after a read error so (diff) | |
download | gnupg-b67d342b9d79717cade1b165effb3683794be935.tar.gz gnupg-b67d342b9d79717cade1b165effb3683794be935.zip |
* configure.ac: Add --with-mailprog to override the use of sendmail with
another MTA. We can use anything that follows the "$MAILPROG -t"
convention.
-rw-r--r-- | ChangeLog | 6 | ||||
-rw-r--r-- | configure.ac | 22 |
2 files changed, 23 insertions, 5 deletions
@@ -1,3 +1,9 @@ +2002-07-08 David Shaw <[email protected]> + + * configure.ac: Add --with-mailprog to override the use of + sendmail with another MTA. We can use anything that follows the + "$MAILPROG -t" convention. + 2002-07-04 David Shaw <[email protected]> * configure.ac: --enable-exec-path should be a 'with'. Fix 'no' diff --git a/configure.ac b/configure.ac index 7551e5002..899d90aff 100644 --- a/configure.ac +++ b/configure.ac @@ -78,7 +78,7 @@ case "$use_static_rnd" in esac AC_ARG_WITH(egd-socket, - [ --with-egd-socket=NAME Use NAME for the EGD socket)], + [ --with-egd-socket=NAME use NAME for the EGD socket], egd_socket_name="$withval", egd_socket_name="" ) AC_DEFINE_UNQUOTED(EGD_SOCKET_NAME, "$egd_socket_name", [Define if you don't want the default EGD socket name. @@ -393,15 +393,27 @@ fi AC_SUBST(GPGKEYS_LDAP) AC_SUBST(LDAPLIBS) +dnl This isn't necessarily sendmail itself, but anything that gives a +dnl sendmail-ish interface to the outside world. That includes qmail, +dnl postfix, etc. Basically, anything that can handle "sendmail -t". + if test "$try_mailto" = yes ; then - AC_PATH_PROG(SENDMAIL,sendmail,,$PATH:/usr/sbin:/usr/libexec:/usr/lib) + AC_ARG_WITH(mailprog,[ --with-mailprog=NAME use "NAME -t" for mail transport],,with_mailprog=yes) - if test "$ac_cv_path_SENDMAIL" ; then - GPGKEYS_MAILTO="gpgkeys_mailto" + if test "$with_mailprog" = yes ; then + AC_PATH_PROG(SENDMAIL,sendmail,,$PATH:/usr/sbin:/usr/libexec:/usr/lib) + if test "$ac_cv_path_SENDMAIL" ; then + GPGKEYS_MAILTO="gpgkeys_mailto" fi + elif test "$with_mailprog" != no ; then + AC_MSG_CHECKING([for a mail transport program]) + AC_SUBST(SENDMAIL,$with_mailprog) + AC_MSG_RESULT($with_mailprog) + GPGKEYS_MAILTO="gpgkeys_mailto" fi -AC_SUBST(GPGKEYS_MAILTO) +fi +AC_SUBST(GPGKEYS_MAILTO) AC_SUBST(GPGKEYS_HKP) case "${target}" in |