aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-12-13 19:48:31 +0000
committerDavid Shaw <[email protected]>2006-12-13 19:48:31 +0000
commitb26e95cf703ad8697890d3fedc51e2ea55ff94b9 (patch)
tree2e1c7026c2471a3a4cc3610f89a129fff3804b36
parentAdded missing files. (diff)
downloadgnupg-b26e95cf703ad8697890d3fedc51e2ea55ff94b9.tar.gz
gnupg-b26e95cf703ad8697890d3fedc51e2ea55ff94b9.zip
Some build fixes for platforms like OSX where we use the built-in libintl.
-rw-r--r--common/ChangeLog5
-rw-r--r--common/Makefile.am2
-rw-r--r--tools/ChangeLog5
-rw-r--r--tools/Makefile.am2
4 files changed, 12 insertions, 2 deletions
diff --git a/common/ChangeLog b/common/ChangeLog
index 141838a9c..6e7fa6c00 100644
--- a/common/ChangeLog
+++ b/common/ChangeLog
@@ -1,3 +1,8 @@
+2006-12-13 David Shaw <[email protected]>
+
+ * Makefile.am (AM_CPPFLAGS): Include intl/ so we can reference the
+ built-in headers.
+
2006-11-23 Werner Koch <[email protected]>
* http.c: Include i18n.h
diff --git a/common/Makefile.am b/common/Makefile.am
index 57056de3b..f2b28c45c 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -24,7 +24,7 @@ noinst_LIBRARIES = libcommon.a libcommonpth.a libsimple-pwquery.a libgpgrl.a
noinst_PROGRAMS = $(module_tests)
TESTS = $(module_tests)
-AM_CPPFLAGS = -I$(top_srcdir)/gl
+AM_CPPFLAGS = -I$(top_srcdir)/gl -I$(top_srcdir)/intl
AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(KSBA_CFLAGS)
diff --git a/tools/ChangeLog b/tools/ChangeLog
index ef51ad743..47e0a589b 100644
--- a/tools/ChangeLog
+++ b/tools/ChangeLog
@@ -1,3 +1,8 @@
+2006-12-13 David Shaw <[email protected]>
+
+ * Makefile.am (gpgsplit_LDADD): Link to LIBINTL if we're using the
+ built-in code.
+
2006-12-07 David Shaw <[email protected]>
* Makefile.am: Link to iconv for jnlib dependency.
diff --git a/tools/Makefile.am b/tools/Makefile.am
index be492c056..fd7f8a431 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -55,7 +55,7 @@ common_libs = ../jnlib/libjnlib.a ../common/libcommon.a ../gl/libgnu.a
pwquery_libs = ../common/libsimple-pwquery.a
gpgsplit_LDADD = $(common_libs) $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) \
- $(ZLIBS) $(LIBICONV)
+ $(ZLIBS) $(LIBINTL) $(LIBICONV)
gpgconf_SOURCES = gpgconf.c gpgconf.h gpgconf-comp.c no-libgcrypt.c