aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-02-20 15:10:36 +0000
committerDavid Shaw <[email protected]>2004-02-20 15:10:36 +0000
commita3ba17e09eaf08982b0d61defe630ace67eedc53 (patch)
tree005d90a9dbf572d9b73a1a9062a442bea22b3539
parent* mkdtemp.c: Removed. (diff)
downloadgnupg-a3ba17e09eaf08982b0d61defe630ace67eedc53.tar.gz
gnupg-a3ba17e09eaf08982b0d61defe630ace67eedc53.zip
* mkdtemp.c: New (moved from g10/), setenv.c: New, unsetenv.c: New.
* Makefile.am: Include @LIBOBJS@ for replacement functions.
-rw-r--r--util/ChangeLog7
-rw-r--r--util/Makefile.am5
-rw-r--r--util/mkdtemp.c98
-rw-r--r--util/setenv.c51
-rw-r--r--util/unsetenv.c58
5 files changed, 217 insertions, 2 deletions
diff --git a/util/ChangeLog b/util/ChangeLog
index fd5d84da9..f7abb8e57 100644
--- a/util/ChangeLog
+++ b/util/ChangeLog
@@ -1,3 +1,10 @@
+2004-02-20 David Shaw <[email protected]>
+
+ * mkdtemp.c: New (moved from g10/), setenv.c: New, unsetenv.c:
+ New.
+
+ * Makefile.am: Include @LIBOBJS@ for replacement functions.
+
2004-01-15 David Shaw <[email protected]>
* argparse.c (default_strusage): Update copyright date.
diff --git a/util/Makefile.am b/util/Makefile.am
index 59896b1a4..973f36c10 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -29,8 +29,9 @@ libutil_a_SOURCES = logger.c fileutil.c miscutil.c strgutil.c \
ttyio.c argparse.c memory.c secmem.c errors.c iobuf.c \
dotlock.c http.c srv.h srv.c simple-gettext.c w32reg.c
-libutil_a_DEPENDENCIES = @REGEX_O@
-libutil_a_LIBADD = @REGEX_O@
+libutil_a_DEPENDENCIES = @LIBOBJS@ @REGEX_O@
+# LIBOBJS is for the replacement functions
+libutil_a_LIBADD = @LIBOBJS@ @REGEX_O@
http-test: http.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. $(INCLUDES) $(LDFLAGS) -g -Wall \
diff --git a/util/mkdtemp.c b/util/mkdtemp.c
new file mode 100644
index 000000000..3abdc1da6
--- /dev/null
+++ b/util/mkdtemp.c
@@ -0,0 +1,98 @@
+/* mkdtemp.c - libc replacement function
+ * Copyright (C) 2001 Free Software Foundation, Inc.
+ *
+ * This file is part of GnuPG.
+ *
+ * GnuPG is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * GnuPG is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
+/* This is a replacement function for mkdtemp in case the platform
+ we're building on (like mine!) doesn't have it. */
+
+#include <config.h>
+#include <string.h>
+#include <errno.h>
+#include <sys/stat.h>
+#include <sys/types.h>
+#include <fcntl.h>
+#include <unistd.h>
+#include "types.h"
+#include "cipher.h"
+
+#ifdef MKDIR_TAKES_ONE_ARG
+# undef mkdir
+# define mkdir(a,b) mkdir(a)
+#endif
+
+char *mkdtemp(char *template)
+{
+ unsigned int attempts,idx,count=0;
+ byte *ch;
+
+ idx=strlen(template);
+
+ /* Walk backwards to count all the Xes */
+ while(idx>0 && template[idx-1]=='X')
+ {
+ count++;
+ idx--;
+ }
+
+ if(count==0)
+ {
+ errno=EINVAL;
+ return NULL;
+ }
+
+ ch=&template[idx];
+
+ /* Try 4 times to make the temp directory */
+ for(attempts=0;attempts<4;attempts++)
+ {
+ unsigned int remaining=count;
+ char *marker=ch;
+ byte *randombits;
+
+ idx=0;
+
+ /* Using really random bits is probably overkill here. The
+ worst thing that can happen with a directory name collision
+ is that the function will return an error. */
+
+ randombits=get_random_bits(4*remaining,0,0);
+
+ while(remaining>1)
+ {
+ sprintf(marker,"%02X",randombits[idx++]);
+ marker+=2;
+ remaining-=2;
+ }
+
+ /* Any leftover Xes? get_random_bits rounds up to full bytes,
+ so this is safe. */
+ if(remaining>0)
+ sprintf(marker,"%X",randombits[idx]&0xF);
+
+ m_free(randombits);
+
+ if(mkdir(template,0700)==0)
+ break;
+ }
+
+ if(attempts==4)
+ return NULL; /* keeps the errno from mkdir, whatever it is */
+
+ return template;
+}
diff --git a/util/setenv.c b/util/setenv.c
new file mode 100644
index 000000000..9175e6f30
--- /dev/null
+++ b/util/setenv.c
@@ -0,0 +1,51 @@
+/* setenv.c - libc replacement function
+ * Copyright (C) 2004 Free Software Foundation, Inc.
+ *
+ * This file is part of GnuPG.
+ *
+ * GnuPG is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * GnuPG is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
+#include <config.h>
+#include <string.h>
+#include <errno.h>
+#include <stdlib.h>
+
+/* Implement setenv in terms of putenv. Alas, the nature of setenv is
+ to be leaky... */
+int
+setenv(const char *name, const char *value, int overwrite)
+{
+ char *item=NULL;
+
+ if (name == NULL || *name == '\0' || strchr (name, '=') != NULL)
+ {
+ errno=EINVAL;
+ return -1;
+ }
+
+ item=malloc(strlen(name)+1+strlen(value)+1);
+ if(!item)
+ {
+ errno=ENOMEM;
+ return -1;
+ }
+
+ strcpy(item,name);
+ strcat(item,"=");
+ strcat(item,value);
+
+ return putenv(item);
+}
diff --git a/util/unsetenv.c b/util/unsetenv.c
new file mode 100644
index 000000000..9c4f4e95c
--- /dev/null
+++ b/util/unsetenv.c
@@ -0,0 +1,58 @@
+/* unsetenv.c - libc replacement function
+ * Copyright (C) 2004 Free Software Foundation, Inc.
+ *
+ * This file is part of GnuPG.
+ *
+ * GnuPG is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * GnuPG is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
+#include <config.h>
+#include <string.h>
+#include <errno.h>
+
+extern char **environ;
+
+/* Basically borrowed from glibc */
+int
+unsetenv2 (const char *name)
+{
+ size_t len;
+ char **ep;
+
+ if (name == NULL || *name == '\0' || strchr (name, '=') != NULL)
+ {
+ errno=EINVAL;
+ return -1;
+ }
+
+ len = strlen (name);
+
+ ep = environ;
+ while (*ep != NULL)
+ if (!strncmp (*ep, name, len) && (*ep)[len] == '=')
+ {
+ /* Found it. Remove this pointer by moving later ones back. */
+ char **dp = ep;
+
+ do
+ dp[0] = dp[1];
+ while (*dp++);
+ /* Continue the loop in case NAME appears again. */
+ }
+ else
+ ++ep;
+
+ return 0;
+}