aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-12-01 00:48:16 +0000
committerDavid Shaw <[email protected]>2003-12-01 00:48:16 +0000
commita32a3a863e1b27c891b36ba1ce13147678660893 (patch)
tree63e4c8b207a7a51803e4816fb1ce21301f4395b0
parent* pubkey.c (setup_pubkey_table): Only include RSA if USE_RSA is defined. (diff)
downloadgnupg-a32a3a863e1b27c891b36ba1ce13147678660893.tar.gz
gnupg-a32a3a863e1b27c891b36ba1ce13147678660893.zip
* NEWS: Note --disable-rsa.
* configure.ac: Add --disable-rsa. * README: Add --with-zlib, --with-bzip2, --without-bzip2, --disable-rsa, and --enable-minimal. Update gettext version.
-rw-r--r--ChangeLog7
-rw-r--r--NEWS5
-rw-r--r--README49
-rw-r--r--configure.ac11
4 files changed, 62 insertions, 10 deletions
diff --git a/ChangeLog b/ChangeLog
index 02436fb69..6a081ccb5 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,12 @@
2003-11-30 David Shaw <[email protected]>
+ * NEWS: Note --disable-rsa.
+
+ * configure.ac: Add --disable-rsa.
+
+ * README: Add --with-zlib, --with-bzip2, --without-bzip2,
+ --disable-rsa, and --enable-minimal. Update gettext version.
+
* README: Update version number. Add BZIP2. Remove Elgamal
sign+encrypt.
diff --git a/NEWS b/NEWS
index b19ea7148..323279d96 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,11 @@
Noteworthy changes in version 1.3.5 (unreleased)
------------------------------------------------
+ * The configure options --enable-rsa and --disable-rsa can now be
+ used to enable or disable RSA support. This can be useful for
+ embedded use where space is tight. --enable-minimal includes
+ --disable-rsa.
+
Noteworthy changes in version 1.3.4 (2003-11-27)
------------------------------------------------
diff --git a/README b/README
index d45d2ad7e..5cf230297 100644
--- a/README
+++ b/README
@@ -409,7 +409,8 @@
"123434343434343C3434343434343734349A3434"
"0E12343434343434343434EAB3484343434343434"
- The first one is MD5 the others are ripemd160 or sha1.
+ The first one is a short fingerprint for PGP 2.x style keys.
+ The others are long fingerprints for OpenPGP keys.
* By an exact string:
@@ -489,6 +490,15 @@
Forces usage of the local zlib sources. Default is
to use the (shared) library of the system.
+ --with-zlib=<DIR>
+ Look for the system zlib in DIR.
+
+ --with-bzip2=<DIR>
+ Look for the system libbz2 in DIR.
+
+ --without-bzip2
+ Disable the BZIP2 compression algorithm.
+
--with-included-gettext
Forces usage of the local gettext sources instead of
the one provided by your system.
@@ -533,6 +543,11 @@
disable any ability for the user to change it in
their options file.
+ --disable-rsa
+ Removes support for the RSA public key algorithm.
+ This can give a smaller gpg binary for places
+ where space is tight.
+
--disable-idea
--disable-cast5
--disable-blowfish
@@ -540,27 +555,41 @@
--disable-twofish
--disable-sha256
--disable-sha512
- Removes support for the selected algorithm. This
- can give a smaller gpg binary for places where
- space is tight.
+ Removes support for the selected symmetric
+ algorithm. This can give a smaller gpg binary for
+ places where space is tight.
- *** Note, that if there are existing keys that
+ **** Note that if there are existing keys that
have one of these algorithms as a preference,
messages may be received that use one of these
algorithms and you will not be able to decrypt the
- message! ***
+ message! ****
- A public key preference list can be updated to
+ The public key preference list can be updated to
match the list of available algorithms by using
- 'gpg --edit (thekey)', and running the "updpref"
- command.
+ "gpg --edit-key (thekey)", and running the
+ "updpref" command.
+
+ --enable-minimal
+ Build the smallest gpg possible (disables all
+ optional algorithms, disables keyserver access,
+ and disables photo IDs). Specifically, this means
+ --disable-rsa --disable-idea, --disable-cast5,
+ --disable-blowfish, --disable-aes,
+ --disable-twofish, --disable-sha256,
+ --disable-sha512, --without-bzip2, and
+ --disable-exec. Configure command lines are read
+ from left to right, so if you want to have an
+ "almost minimal" configuration, you can do (for
+ example) "--enable-minimal --enable-rsa" to have
+ RSA added to the minimal build.
Installation Problems
---------------------
If you get unresolved externals "gettext" you should run configure
again with the option "--with-included-gettext"; this is version
- 0.10.40 which is available at ftp.gnu.org.
+ 0.12.1 which is available at ftp.gnu.org.
If you have other compile problems, try the configure options
"--with-included-zlib" or "--disable-nls" (See ABOUT-NLS) or
diff --git a/configure.ac b/configure.ac
index dd0c77bc1..6d9449164 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,6 +112,7 @@ dnl binary
try_extensions=no
+use_rsa=yes
use_idea=yes
use_cast5=yes
use_blowfish=yes
@@ -124,6 +125,7 @@ use_exec=yes
AC_ARG_ENABLE(minimal,
AC_HELP_STRING([--enable-minimal],[build the smallest gpg binary possible]),
+ use_rsa=no
use_idea=no
use_cast5=no
use_blowfish=no
@@ -134,6 +136,15 @@ AC_ARG_ENABLE(minimal,
use_bzip2=no
use_exec=no)
+AC_MSG_CHECKING([whether to enable the RSA public key algorithm])
+AC_ARG_ENABLE(rsa,
+ AC_HELP_STRING([--disable-rsa],[disable the RSA public key algorithm]),
+ use_rsa=$enableval)
+AC_MSG_RESULT($use_rsa)
+if test x"$use_rsa" = xyes ; then
+ AC_DEFINE(USE_RSA,1,[Define to include the RSA public key algorithm])
+fi
+
AC_MSG_CHECKING([whether to enable the IDEA cipher])
AC_ARG_ENABLE(idea,
AC_HELP_STRING([--disable-idea],[disable the IDEA cipher]),