aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2002-07-03 04:05:06 +0000
committerDavid Shaw <[email protected]>2002-07-03 04:05:06 +0000
commit985b36ac07e99352e9a53f9bb3c263ba6848c0ec (patch)
tree3425157aed7cfc3d0b5052a48cf99859fc2fa3da
parent* exec.h, exec.c (set_exec_path, exec_write), g10.c (main): If (diff)
downloadgnupg-985b36ac07e99352e9a53f9bb3c263ba6848c0ec.tar.gz
gnupg-985b36ac07e99352e9a53f9bb3c263ba6848c0ec.zip
* configure.ac: Allow setting USE_EXEC_PATH to lock the exec-path to a
fixed value.
-rw-r--r--ChangeLog5
-rw-r--r--configure.ac11
2 files changed, 16 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 1404878b8..f0cb83c57 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2002-07-03 David Shaw <[email protected]>
+
+ * configure.ac: Allow setting USE_EXEC_PATH to lock the exec-path
+ to a fixed value.
+
2002-07-01 Werner Koch <[email protected]>
* configure.ac: Set version number to 1.1.91.
diff --git a/configure.ac b/configure.ac
index da1e345cd..65bc08726 100644
--- a/configure.ac
+++ b/configure.ac
@@ -130,6 +130,17 @@ if test "$use_exec" = no ; then
fi
if test "$use_exec" = yes ; then
+ AC_MSG_CHECKING([for a restricted exec-path])
+ AC_ARG_WITH(exec-path,
+ [ --with-exec-path=PATH restrict exec-path to PATH],
+ [if test "$withval" = yes ; then
+ withval=no
+ else
+ AC_DEFINE_UNQUOTED(USE_EXEC_PATH,"$withval",
+ [restrict exec-path to this])
+ fi],withval=no)
+ AC_MSG_RESULT($withval)
+
AC_MSG_CHECKING([whether LDAP keyserver support is requested])
AC_ARG_ENABLE(ldap,
[ --disable-ldap disable LDAP keyserver interface],