aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2016-01-13 08:22:37 +0000
committerNIIBE Yutaka <[email protected]>2016-01-13 08:22:37 +0000
commit96237b9a63a50aed1884cb06f84279b977d6a8fa (patch)
tree36699a6c857a8af5f4c52e18853a1740b09fc2f4
parentssh: Accept OpenSSH *cert-v01 key variants. (diff)
downloadgnupg-96237b9a63a50aed1884cb06f84279b977d6a8fa.tar.gz
gnupg-96237b9a63a50aed1884cb06f84279b977d6a8fa.zip
Fix to support git worktree.
* autogen.sh, Makefile.am, doc/Makefile.am: Use -e for testing .git. -- Signed-off-by: NIIBE Yutaka <[email protected]>
-rw-r--r--Makefile.am2
-rwxr-xr-xautogen.sh2
-rw-r--r--doc/Makefile.am2
3 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e213f3bc..8bff2ef94 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -120,7 +120,7 @@ endif
gen_start_date = 2011-12-01T06:00:00
.PHONY: gen-ChangeLog
gen-ChangeLog:
- if test -d $(top_srcdir)/.git; then \
+ if test -e $(top_srcdir)/.git; then \
(cd $(top_srcdir) && \
$(GITLOG_TO_CHANGELOG) --append-dot --tear-off \
--amend=build-aux/git-log-fix \
diff --git a/autogen.sh b/autogen.sh
index 3fe24ead8..7d843bda0 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -214,7 +214,7 @@ if [ "$myhost" = "find-version" ]; then
esac
beta=no
- if [ -d .git ]; then
+ if [ -e .git ]; then
ingit=yes
tmp=$(git describe --match "${matchstr1}" --long 2>/dev/null)
if [ -n "$tmp" ]; then
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 5449d07a9..a1a570c38 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -136,7 +136,7 @@ dist-hook: defsincdate
defsincdate: $(gnupg_TEXINFOS)
: >defsincdate ; \
- if test -d $(top_srcdir)/.git; then \
+ if test -e $(top_srcdir)/.git; then \
(cd $(srcdir) && git log -1 --format='%ct' \
-- $(gnupg_TEXINFOS) 2>/dev/null) >>defsincdate; \
fi