diff options
author | David Shaw <[email protected]> | 2005-04-16 18:20:01 +0000 |
---|---|---|
committer | David Shaw <[email protected]> | 2005-04-16 18:20:01 +0000 |
commit | 799f97ceeea6589d3127a4051f745fc5c64342d5 (patch) | |
tree | a54ec812ca405366171b2d19a5fe32b6ef29e8e0 | |
parent | Check for memrchr() (diff) | |
download | gnupg-799f97ceeea6589d3127a4051f745fc5c64342d5.tar.gz gnupg-799f97ceeea6589d3127a4051f745fc5c64342d5.zip |
* configure.ac: Add --disable-old-hkp option that can be used along
with --with-libcurl to build the curl version of HKP.
-rw-r--r-- | ChangeLog | 5 | ||||
-rw-r--r-- | configure.ac | 8 |
2 files changed, 13 insertions, 0 deletions
@@ -1,3 +1,8 @@ +2005-04-16 David Shaw <[email protected]> + + * configure.ac: Add --disable-old-hkp option that can be used + along with --with-libcurl to build the curl version of HKP. + 2005-04-12 David Shaw <[email protected]> * configure.ac: Check for memrchr() diff --git a/configure.ac b/configure.ac index 0656284cd..e27f5aedd 100644 --- a/configure.ac +++ b/configure.ac @@ -635,6 +635,8 @@ fi # Are we doing HTTP? +old_hkp=yes + if test x"$try_http" = xyes ; then if test x$libcurl_protocol_HTTP = xyes ; then AC_SUBST(GPGKEYS_CURL,"gpgkeys_curl$EXEEXT") @@ -642,11 +644,17 @@ if test x"$try_http" = xyes ; then if test x$libcurl_protocol_HTTPS = xyes ; then AC_DEFINE(HTTPS_VIA_LIBCURL,1,[Define if HTTPS is handled via libcurl]) fi + + AC_ARG_ENABLE(old-hkp, + AC_HELP_STRING([--disable-old-hkp],[disable old HKP processing code and use the new]),old_hkp=$enableval) + else AC_SUBST(GPGKEYS_HTTP,"gpgkeys_http$EXEEXT") fi fi +AM_CONDITIONAL(OLD_HKP,test x"$old_hkp" != xno) + # Are we doing FTP? We only do FTP if we have libcurl. if test x"$try_ftp" = xyes && test x$libcurl_protocol_FTP = xyes ; then |