aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-04-27 16:20:13 +0000
committerDavid Shaw <[email protected]>2006-04-27 16:20:13 +0000
commit76d69cd56a7f9bf494a296cae527f0abfeeaf2e9 (patch)
tree7151dcd6b7bd49caf41afcef0a3d9430520535d4
parent(keyserver_import_cert): Show warning if there is a CERT fingerprint, (diff)
downloadgnupg-76d69cd56a7f9bf494a296cae527f0abfeeaf2e9.tar.gz
gnupg-76d69cd56a7f9bf494a296cae527f0abfeeaf2e9.zip
* NEWS: Note SHA-224 and DSA2.
* configure.ac: Remove --enable-old-keyserver-helpers. Comment out --enable-m-guard for now.
-rw-r--r--ChangeLog7
-rw-r--r--NEWS10
-rw-r--r--configure.ac47
3 files changed, 40 insertions, 24 deletions
diff --git a/ChangeLog b/ChangeLog
index 4d5266072..d43a69181 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+2006-04-27 David Shaw <[email protected]>
+
+ * NEWS: Note SHA-224 and DSA2.
+
+ * configure.ac: Remove --enable-old-keyserver-helpers. Comment
+ out --enable-m-guard for now.
+
2006-04-12 Werner Koch <[email protected]>
* configure.ac: Print version at end of run.
diff --git a/NEWS b/NEWS
index 7b39e986d..9600de8ac 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,16 @@
Noteworthy changes in version 1.4.4
------------------------------------------------
+ * Added support for the SHA-224 hash. Like the SHA-384 hash, it
+ is mainly useful when DSS (the US Digital Signature Standard)
+ compatibility is desired.
+
+ * Added support for the latest update to DSA keys and signatures.
+ This allows for larger keys than 1024 bits and hashes other than
+ SHA-1 and RIPEMD/160. Note that not all OpenPGP implementations
+ can handle these new keys and signatures yet. See
+ "--enable-dsa2" in the manual for more information.
+
Noteworthy changes in version 1.4.3 (2006-04-03)
------------------------------------------------
diff --git a/configure.ac b/configure.ac
index a7d7bb934..eb6e77021 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,14 +100,14 @@ AC_ARG_ENABLE(asm,
try_asm_modules=$enableval, try_asm_modules=yes)
AC_MSG_RESULT($try_asm_modules)
-AC_MSG_CHECKING([whether memory guard is requested])
-AC_ARG_ENABLE(m-guard,
- [ --enable-m-guard enable memory guard facility],
- use_m_guard=$enableval, use_m_guard=no)
-AC_MSG_RESULT($use_m_guard)
-if test "$use_m_guard" = yes ; then
- AC_DEFINE(M_GUARD,1,[Define to use the (obsolete) malloc guarding feature])
-fi
+dnl AC_MSG_CHECKING([whether memory guard is requested])
+dnl AC_ARG_ENABLE(m-guard,
+dnl [ --enable-m-guard enable memory guard facility],
+dnl use_m_guard=$enableval, use_m_guard=no)
+dnl AC_MSG_RESULT($use_m_guard)
+dnl if test "$use_m_guard" = yes ; then
+dnl AC_DEFINE(M_GUARD,1,[Define to use the (obsolete) malloc guarding feature])
+dnl fi
# We don't have a test to check whether as(1) knows about the
# non executable stack option. Thus we provide an option to enable
@@ -262,11 +262,11 @@ fi
AC_MSG_CHECKING([whether to enable the SHA-256 digest])
AC_ARG_ENABLE(sha256,
- AC_HELP_STRING([--disable-sha256],[disable the SHA-256 digest]),
+ AC_HELP_STRING([--disable-sha256],[disable the SHA-224 and SHA-256 digests]),
use_sha256=$enableval)
AC_MSG_RESULT($use_sha256)
if test x"$use_sha256" = xyes ; then
- AC_DEFINE(USE_SHA256,1,[Define to include the SHA-256 digest])
+ AC_DEFINE(USE_SHA256,1,[Define to include the SHA-224 and SHA-256 digests])
fi
dnl SHA512 is defined only after we confirm 64-bit support later
@@ -346,6 +346,13 @@ dnl LDAP is defined only after we confirm the library is available later
try_finger=$enableval, try_finger=yes)
AC_MSG_RESULT($try_finger)
+ AC_MSG_CHECKING([whether generic object key fetching support is requested])
+ AC_ARG_ENABLE(generic,
+ AC_HELP_STRING([--disable-generic],
+ [disable generic object key fetching interface only]),
+ try_generic=$enableval, try_generic=yes)
+ AC_MSG_RESULT($try_generic)
+
AC_MSG_CHECKING([whether email keyserver support is requested])
AC_ARG_ENABLE(mailto,
AC_HELP_STRING([--enable-mailto],
@@ -671,23 +678,15 @@ if test "$try_ldap" = yes ; then
GNUPG_CHECK_LDAP($NETLIBS)
fi
-# Which keyserver helpers are we building?
-
-AC_ARG_ENABLE(old-keyserver-helpers,
- AC_HELP_STRING([--enable-old-keyserver-helpers],[enable old keyserver helpers]),old_ks=$enableval,old_ks=no)
-
-if test "$old_ks" = yes ; then
- AC_SUBST(GPGKEYS_HTTP,"gpgkeys_http$EXEEXT")
-else
- LIBCURL_CHECK_CONFIG([yes],,[with_curl=yes],[fake_curl=yes])
- AC_SUBST(GPGKEYS_CURL,"gpgkeys_curl$EXEEXT")
-fi
+# Check for curl. We fake the curl API if libcurl isn't installed.
+LIBCURL_CHECK_CONFIG([yes],,,[fake_curl=yes])
AM_CONDITIONAL(FAKE_CURL,test x"$fake_curl" = xyes)
-AM_CONDITIONAL(WITH_CURL,test x"$with_curl" = xyes || test x"$fake_curl" = xyes)
-if test x"$fake_curl" = xyes ; then
- AC_DEFINE(FAKE_CURL,1,[define to fake the libcurl API internally])
+# Generic, for us, means curl
+
+if test x"$try_generic" = xyes ; then
+ AC_SUBST(GPGKEYS_CURL,"gpgkeys_curl$EXEEXT")
fi
dnl This isn't necessarily sendmail itself, but anything that gives a