aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2007-04-13 11:45:05 +0000
committerWerner Koch <[email protected]>2007-04-13 11:45:05 +0000
commit6ae6e18d5fc677d72aad050fd6bb8323836dd929 (patch)
treebcb900b825a7a6f36ebb69858fd6ad8ce80ab27a
parent* parse-packet.c (parse_marker): New. Enforce that the marker (diff)
downloadgnupg-6ae6e18d5fc677d72aad050fd6bb8323836dd929.tar.gz
gnupg-6ae6e18d5fc677d72aad050fd6bb8323836dd929.zip
g10/ and sm/
* call-agent.c (start_agent): Don't use log_error when using the fallback hack to start the agent. This is bug 782. scripts/ * mail-to-translators: Copied from 1.4. and adjusted. tools/ * gpgconf-comp.c: Allow changing of --allow-mark-trusted. * gpg-connect-agent.c (main): New option --decode and commands decode and undecode. (read_and_print_response): Implement option.
-rw-r--r--README.maint11
-rw-r--r--TODO5
-rw-r--r--doc/ChangeLog5
-rw-r--r--doc/Makefile.am2
-rw-r--r--doc/examples/README2
-rw-r--r--doc/examples/gpgconf.conf5
-rw-r--r--doc/gpg.texi22
-rw-r--r--g10/ChangeLog5
-rw-r--r--g10/call-agent.c2
-rw-r--r--scripts/ChangeLog4
-rwxr-xr-xscripts/mail-to-translators79
-rw-r--r--sm/ChangeLog5
-rw-r--r--sm/call-agent.c2
-rw-r--r--tools/ChangeLog2
-rw-r--r--tools/gpgconf-comp.c2
15 files changed, 144 insertions, 9 deletions
diff --git a/README.maint b/README.maint
index e74da9297..8bd169a0f 100644
--- a/README.maint
+++ b/README.maint
@@ -3,6 +3,17 @@
Here are some notes on how to maintain GnuPG.
+Release Planning:
+=================
+
+If you are planning a new release and strings have changed you should
+send a notification to all tyranslators, so that they have time to
+update their translations. scripts/mail-to-translators is useful for
+this. It might need some tweaking and it needs to be armored for
+actual sending. Running it as is to see what will happen is a good
+idea, though.
+
+
Release process:
================
diff --git a/TODO b/TODO
index 16471f16c..8698c910f 100644
--- a/TODO
+++ b/TODO
@@ -1,6 +1,6 @@
-*- outline -*-
-* src/base64
+* src/base64
** Make parsing more robust
Currently we don't cope with overlong lines in the best way.
** Check that we really release the ksba reader/writer objects.
@@ -129,4 +129,7 @@
scdaemon stays as a zombie and gpg-agent does not perform any more
commands.
+* configure check
+** Update autoconf and use AC_PROG_CC_C89
+ to make sure that a compiant compiler is used
diff --git a/doc/ChangeLog b/doc/ChangeLog
index db0c5bae1..5120d1ff4 100644
--- a/doc/ChangeLog
+++ b/doc/ChangeLog
@@ -1,3 +1,8 @@
+2007-04-10 Werner Koch <[email protected]>
+
+ * gpg.texi (GPG Configuration Options): Document --batch, no-tty,
+ --yes and --no.
+
2007-03-08 Werner Koch <[email protected]>
* gnupg-logo.png, gnupg-logo.eps, gnupg-logo.pdf: New.
diff --git a/doc/Makefile.am b/doc/Makefile.am
index b1e903934..5d25c828a 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -23,7 +23,7 @@ examples = examples/README examples/scd-event examples/trustlist.txt \
examples/gpgconf.conf
EXTRA_DIST = DETAILS HACKING TRANSLATE OpenPGP KEYSERVER samplekeys.asc \
- gnupg-logo.eps gnupg-logo.jpg gnupg-logo.pdf \
+ gnupg-logo.eps gnupg-logo.pdf \
gnupg-card-architecture.eps gnupg-card-architecture.png \
gnupg-card-architecture.pdf \
faq.raw FAQ faq.html gnupg7.texi \
diff --git a/doc/examples/README b/doc/examples/README
index 341dda88a..344482283 100644
--- a/doc/examples/README
+++ b/doc/examples/README
@@ -6,4 +6,4 @@ scd-event A handler script used with scdaemon
trustlist.txt A list of trustworthy root certificates
(Please check yourself whether you actually trust them)
-
+gpgconf.conf A sample configuration file for gpgconf.
diff --git a/doc/examples/gpgconf.conf b/doc/examples/gpgconf.conf
index 194ed7938..c9012137d 100644
--- a/doc/examples/gpgconf.conf
+++ b/doc/examples/gpgconf.conf
@@ -52,8 +52,7 @@
#-------------------------------------------------------------------
-# Allow all users to change the allow-mark-trusted option.
-# (This was the default prior to gnupg 2.0.3)
-* gpg-agent allow-mark-trusted [change]
+# Deny all users to change the allow-mark-trusted option.
+* gpg-agent allow-mark-trusted [no-change]
diff --git a/doc/gpg.texi b/doc/gpg.texi
index e70c32341..6d8ad2f7a 100644
--- a/doc/gpg.texi
+++ b/doc/gpg.texi
@@ -908,6 +908,28 @@ Reset verbose level to 0.
@opindex quiet
Try to be as quiet as possible.
+@item --batch
+@itemx --no-batch
+@opindex batch
+@opindex no-batch
+Use batch mode. Never ask, do not allow interactive commands.
+@option{--no-batch} disables this option.
+
+@item --no-tty
+@opindex no-tty
+Make sure that the TTY (terminal) is never used for any output.
+This option is needed in some cases because GnuPG sometimes prints
+warnings to the TTY even if @option{--batch} is used.
+
+@item --yes
+@opindex yes
+Assume "yes" on most questions.
+
+@item --no
+@opindex no
+Assume "no" on most questions.
+
+
@item --list-options @code{parameters}
@opindex list-options
This is a space or comma delimited string that gives options used when
diff --git a/g10/ChangeLog b/g10/ChangeLog
index 01071dcd0..bbd969982 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,3 +1,8 @@
+2007-04-13 Werner Koch <[email protected]>
+
+ * call-agent.c (start_agent): Don't use log_error when using the
+ fallback hack to start the agent. This is bug 782.
+
2007-04-05 David Shaw <[email protected]>
From STABLE-BRANCH-1-4
diff --git a/g10/call-agent.c b/g10/call-agent.c
index b5e76fdbf..637669176 100644
--- a/g10/call-agent.c
+++ b/g10/call-agent.c
@@ -157,7 +157,7 @@ start_agent (void)
xfree (infostr);
if (gpg_err_code (rc) == GPG_ERR_ASS_CONNECT_FAILED)
{
- log_error (_("can't connect to the agent - trying fall back\n"));
+ log_info (_("can't connect to the agent - trying fall back\n"));
force_pipe_server = 1;
return start_agent ();
}
diff --git a/scripts/ChangeLog b/scripts/ChangeLog
index 5c8b95c8c..2f8e8521a 100644
--- a/scripts/ChangeLog
+++ b/scripts/ChangeLog
@@ -1,3 +1,7 @@
+2007-04-04 Werner Koch <[email protected]>
+
+ * mail-to-translators: Copied from 1.4. and adjusted.
+
2004-09-30 Werner Koch <[email protected]>
* config.guess, config.sub: Updated.
diff --git a/scripts/mail-to-translators b/scripts/mail-to-translators
new file mode 100755
index 000000000..3df59ad7b
--- /dev/null
+++ b/scripts/mail-to-translators
@@ -0,0 +1,79 @@
+#!/bin/sh
+# mail a compressed version of the current translation to the Last-Translator
+#
+
+# remove the colon to armor this script.
+SENDMAIL=": /usr/sbin/sendmail"
+
+for file in *.po; do
+ addr=$(head -100 $file | awk '/^# ?Designated-Translator:/ { printf "%s", $0; exit 0}' | sed 's/.*\(<.*>\).*/\1/')
+ if [ -z "$addr" ]; then
+ addr=$(awk '/Last-Translator:/ { printf "%s", $0; exit 0}' $file | sed 's/.*\(<.*>\).*/\1/')
+ fi
+ ll=$(basename $file .po)
+
+ if ! msgfmt -vc $file 2>&1| egrep -q 'fuzzy|untranslated|error'; then
+ echo "$file: okay" >&2
+ continue;
+ fi
+
+ if ! echo "$addr" | grep -q @ ; then
+ echo "$file: no translator known" >&2
+ continue;
+ fi
+
+ echo "$file: sending to $addr"
+ ( cat <<EOF
+To: $addr
+Mail-Followup-To: [email protected]
+Subject: GnuPG 2.0 translation ($ll)
+Date: $(date -R)
+Mime-Version: 1.0
+Content-Type: multipart/mixed; boundary="=-=-="
+
+--=-=-=
+
+Hi!
+
+We are preparing for a new 2.0 release of GnuPG and like you to ask to
+update your translation.
+
+Please find attached the very latest version of the PO file for your
+GnuPG translation ($file).
+
+It is important to have a basic understanding of GnuPG's functionality
+to do a correct translation. A false translation might lead to
+security problems. Furthermore the TP Robot is not able to handle
+more than one version of a project (we maintain 1.4 and 2.0) and thus
+I'd ask you *not to use the TP Robot* for GnuPG.
+
+Output of msgfmt is:
+$(msgfmt --check --statistics $file 2>&1 | head)
+
+If you are not able to continue the translation work, I suggest to
+pass this message on to another translator and drop a a short note to
+
+
+Thanks,
+
+ Werner
+
+
+--=-=-=
+Content-Type: application/octet-stream
+Content-Disposition: attachment; filename=gnupg-${file}.bz2
+Content-Transfer-Encoding: base64
+
+EOF
+
+bzip2 <$file | mimencode
+
+echo ""
+echo "--=-=-=--"
+echo ""
+ ) | $SENDMAIL -oi "$addr"
+
+done
+
diff --git a/sm/ChangeLog b/sm/ChangeLog
index 4a8e90e56..426e44e8b 100644
--- a/sm/ChangeLog
+++ b/sm/ChangeLog
@@ -1,3 +1,8 @@
+2007-04-13 Werner Koch <[email protected]>
+
+ * call-agent.c (start_agent): Don't use log_error when using the
+ fallback hack to start the agent. This is bug 782.
+
2007-03-20 Werner Koch <[email protected]>
* fingerprint.c (gpgsm_get_fingerprint): Add caching.
diff --git a/sm/call-agent.c b/sm/call-agent.c
index 47f53041d..153f7b34f 100644
--- a/sm/call-agent.c
+++ b/sm/call-agent.c
@@ -164,7 +164,7 @@ start_agent (ctrl_t ctrl)
xfree (infostr);
if (gpg_err_code (rc) == GPG_ERR_ASS_CONNECT_FAILED)
{
- log_error (_("can't connect to the agent - trying fall back\n"));
+ log_info (_("can't connect to the agent - trying fall back\n"));
force_pipe_server = 1;
return start_agent (ctrl);
}
diff --git a/tools/ChangeLog b/tools/ChangeLog
index 7ef39133c..7621bae48 100644
--- a/tools/ChangeLog
+++ b/tools/ChangeLog
@@ -1,5 +1,7 @@
2007-04-03 Werner Koch <[email protected]>
+ * gpgconf-comp.c: Allow changing of --allow-mark-trusted.
+
* gpg-connect-agent.c (main): New option --decode and commands
decode and undecode.
(read_and_print_response): Implement option.
diff --git a/tools/gpgconf-comp.c b/tools/gpgconf-comp.c
index 7bb92ebd9..580972aef 100644
--- a/tools/gpgconf-comp.c
+++ b/tools/gpgconf-comp.c
@@ -498,7 +498,7 @@ static gc_option_t gc_options_gpg_agent[] =
{ "ignore-cache-for-signing", GC_OPT_FLAG_RUNTIME,
GC_LEVEL_BASIC, "gnupg", "do not use the PIN cache when signing",
GC_ARG_TYPE_NONE, GC_BACKEND_GPG_AGENT },
- { "allow-mark-trusted", GC_OPT_FLAG_RUNTIME | GC_OPT_FLAG_NO_CHANGE,
+ { "allow-mark-trusted", GC_OPT_FLAG_RUNTIME,
GC_LEVEL_ADVANCED, "gnupg", "allow clients to mark keys as \"trusted\"",
GC_ARG_TYPE_NONE, GC_BACKEND_GPG_AGENT },
{ "min-passphrase-len", GC_OPT_FLAG_RUNTIME,