aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-12-03 19:12:38 +0000
committerDavid Shaw <[email protected]>2004-12-03 19:12:38 +0000
commit62d19cbd0e4a883b5b10eb320106a2bced154563 (patch)
tree15f115e33be73997ab23098f7a8d75b71def8af7
parent* md.c (string_to_digest_algo): Allow read/write SHA384 and SHA512. (diff)
downloadgnupg-62d19cbd0e4a883b5b10eb320106a2bced154563.tar.gz
gnupg-62d19cbd0e4a883b5b10eb320106a2bced154563.zip
* Makefile.am: The harmless "ignored error" on gpgkeys_ldap install on top
of an existing install is bound to confuse people. Use ln -s -f to force the overwrite.
-rw-r--r--keyserver/ChangeLog6
-rw-r--r--keyserver/Makefile.am2
2 files changed, 7 insertions, 1 deletions
diff --git a/keyserver/ChangeLog b/keyserver/ChangeLog
index d4889ebbf..34d7edb9b 100644
--- a/keyserver/ChangeLog
+++ b/keyserver/ChangeLog
@@ -1,3 +1,9 @@
+2004-12-03 David Shaw <[email protected]>
+
+ * Makefile.am: The harmless "ignored error" on gpgkeys_ldap
+ install on top of an existing install is bound to confuse people.
+ Use ln -s -f to force the overwrite.
+
2004-10-28 David Shaw <[email protected]>
* gpgkeys_finger.c [_WIN32] (connect_server): Fix typo.
diff --git a/keyserver/Makefile.am b/keyserver/Makefile.am
index 37698ca6a..ac172f4f0 100644
--- a/keyserver/Makefile.am
+++ b/keyserver/Makefile.am
@@ -41,7 +41,7 @@ gpgkeys_finger_LDADD = ../util/libutil.a @NETLIBS@ $(other_libs) @GETOPT@ @W32LI
install-exec-hook:
if GPGKEYS_LDAP
- -(cd $(libexecdir) && $(LN_S) gpgkeys_ldap$(EXEEXT) gpgkeys_ldaps$(EXEEXT))
+ (cd $(libexecdir) && $(LN_S) -f gpgkeys_ldap$(EXEEXT) gpgkeys_ldaps$(EXEEXT))
endif
uninstall-hook: