aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-01-03 15:18:24 +0000
committerDavid Shaw <[email protected]>2005-01-03 15:18:24 +0000
commit61197deca8f23ea60fddd37fb0b74bb834fee924 (patch)
tree0478c33553a48c93c377cb90c2e624d0262b4244
parent* Makefile.am, libusb.m4: New libusb check macro. (diff)
downloadgnupg-61197deca8f23ea60fddd37fb0b74bb834fee924.tar.gz
gnupg-61197deca8f23ea60fddd37fb0b74bb834fee924.zip
* configure.ac: Use new GNUPG_CHECK_LIBUSB macro.
-rw-r--r--ChangeLog4
-rw-r--r--configure.ac20
2 files changed, 8 insertions, 16 deletions
diff --git a/ChangeLog b/ChangeLog
index f67f51369..3836f1a72 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2005-01-03 David Shaw <[email protected]>
+
+ * configure.ac: Use new GNUPG_CHECK_LIBUSB macro.
+
2004-12-28 David Shaw <[email protected]>
* configure.ac: Better implementation for the SRV check. We don't
diff --git a/configure.ac b/configure.ac
index ed1983999..4d728bdac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
-dnl Configure.ac script for GnuPG
-dnl Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003
-dnl 2004 Free Software Foundation, Inc.
+dnl configure.ac script for GnuPG
+dnl Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003, 2004,
+dnl 2005 Free Software Foundation, Inc.
dnl
dnl This file is part of GnuPG.
dnl
@@ -1179,20 +1179,8 @@ fi
AM_CONDITIONAL(ENABLE_BZIP2_SUPPORT,test x"$have_bz2" = "xyes")
AC_SUBST(ZLIBS)
-
-#
# libusb allows us to use the integrated CCID smartcard reader driver.
-#
-LIBUSB_LIBS=""
-if test "$card_support" = yes; then
- AC_CHECK_LIB(usb, usb_bulk_write,
- [ LIBUSB_LIBS="$LIBUSB_LIBS -lusb"
- AC_DEFINE(HAVE_LIBUSB,1,
- [defined if libusb is available])
- ])
-fi
-AC_SUBST(LIBUSB_LIBS)
-AC_CHECK_FUNCS(usb_get_busses)
+GNUPG_CHECK_LIBUSB
# Check for readline support
GNUPG_CHECK_READLINE