aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-04-01 12:53:48 +0000
committerJustus Winter <[email protected]>2016-04-01 12:57:27 +0000
commit6060ea898fda499211c9d5030fff41d58f899fb0 (patch)
tree9823e3f12f8555293e91816b2007eb1b7ad0e7f8
parentg10: Remove option --always-trust if compiled without trust models. (diff)
downloadgnupg-6060ea898fda499211c9d5030fff41d58f899fb0.tar.gz
gnupg-6060ea898fda499211c9d5030fff41d58f899fb0.zip
build: Check for conflicting trust model options.
* configure.ac: Disable TOFU if configured without trust models, and check for conflicting options. Signed-off-by: Justus Winter <[email protected]>
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 003e5091a..0163dde0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -263,8 +263,11 @@ AC_MSG_CHECKING([whether to enable TOFU])
AC_ARG_ENABLE(tofu,
AC_HELP_STRING([--disable-tofu],
[disable the TOFU trust model]),
- use_tofu=$enableval, use_tofu=yes)
+ use_tofu=$enableval, use_tofu=$use_trust_models)
AC_MSG_RESULT($use_tofu)
+if test "$use_trust_models" = no && test "$use_tofu" = yes; then
+ AC_MSG_ERROR([both --disable-trust-models and --enable-tofu given])
+fi