aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2003-07-16 13:44:03 +0000
committerWerner Koch <[email protected]>2003-07-16 13:44:03 +0000
commit59e5fb16f6b29dc1e6626e25ff4352637c2eb8d0 (patch)
tree683fc3d056aac8a76a410d24827e3b73ad7ed577
parent* Makefile.am: Add --no-permission-warning to avoid spurious warning when (diff)
downloadgnupg-59e5fb16f6b29dc1e6626e25ff4352637c2eb8d0.tar.gz
gnupg-59e5fb16f6b29dc1e6626e25ff4352637c2eb8d0.zip
* simple-pwquery.c, simple-pwquery.h: Moved to ../common.
* Makefile.am (gpg_protect_tool_LDADD): Add simple-pwquery.o. Removed it from xx_SOURCES.
-rw-r--r--agent/ChangeLog6
-rw-r--r--agent/Makefile.am8
-rw-r--r--agent/protect-tool.c2
3 files changed, 11 insertions, 5 deletions
diff --git a/agent/ChangeLog b/agent/ChangeLog
index 894bb5854..77d84fc19 100644
--- a/agent/ChangeLog
+++ b/agent/ChangeLog
@@ -1,3 +1,9 @@
+2003-07-15 Werner Koch <[email protected]>
+
+ * simple-pwquery.c, simple-pwquery.h: Moved to ../common.
+ * Makefile.am (gpg_protect_tool_LDADD): Add simple-pwquery.o.
+ Removed it from xx_SOURCES.
+
2003-07-04 Werner Koch <[email protected]>
* gpg-agent.c (handle_connections): Kludge to allow use of Pth 1
diff --git a/agent/Makefile.am b/agent/Makefile.am
index 0fa977b20..afd3e302d 100644
--- a/agent/Makefile.am
+++ b/agent/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright (C) 2001 Free Software Foundation, Inc.
+# Copyright (C) 2001, 2003 Free Software Foundation, Inc.
#
# This file is part of GnuPG.
#
@@ -51,10 +51,10 @@ gpg_agent_LDADD = ../jnlib/libjnlib.a ../common/libcommon.a \
gpg_protect_tool_SOURCES = \
protect-tool.c \
protect.c \
- minip12.c minip12.h \
- simple-pwquery.c simple-pwquery.h
+ minip12.c minip12.h
gpg_protect_tool_LDADD = ../jnlib/libjnlib.a \
- ../common/libcommon.a $(LIBGCRYPT_LIBS) -lgpg-error
+ ../common/libcommon.a ../common/libsimple-pwquery.a \
+ $(LIBGCRYPT_LIBS) -lgpg-error
diff --git a/agent/protect-tool.c b/agent/protect-tool.c
index b41730c10..e518c5672 100644
--- a/agent/protect-tool.c
+++ b/agent/protect-tool.c
@@ -709,7 +709,7 @@ sexp_to_kparms (gcry_sexp_t sexp)
return NULL;
}
- /* Paramter names used with RSA. */
+ /* Parameter names used with RSA. */
elems = "nedpqu";
array = xcalloc (strlen(elems) + 1, sizeof *array);
for (idx=0, s=elems; *s; s++, idx++ )