aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2002-08-16 14:09:23 +0000
committerWerner Koch <[email protected]>2002-08-16 14:09:23 +0000
commit5776c03b4c2caa1199e2f267961a569805a65b5e (patch)
treef9d8afe5a165474b6da3e85bc5a6b00c88990f5f
parent* call-agent.c (learn_cb): Special treatment when the issuer (diff)
downloadgnupg-5776c03b4c2caa1199e2f267961a569805a65b5e.tar.gz
gnupg-5776c03b4c2caa1199e2f267961a569805a65b5e.zip
* certpath.c: Renamed to ..
* certchain.c: this. Renamed all all other usages of "path" in the context of certificates to "chain".
-rw-r--r--sm/ChangeLog4
-rw-r--r--sm/Makefile.am4
-rw-r--r--sm/certchain.c2
-rw-r--r--sm/gpgsm.h2
4 files changed, 7 insertions, 5 deletions
diff --git a/sm/ChangeLog b/sm/ChangeLog
index 930af70ea..9853bd363 100644
--- a/sm/ChangeLog
+++ b/sm/ChangeLog
@@ -1,6 +1,8 @@
2002-08-16 Werner Koch <[email protected]>
- Renamed all all usages of "path" with certificates to "chain"
+ * certpath.c: Renamed to ..
+ * certchain.c: this. Renamed all all other usages of "path" in the
+ context of certificates to "chain".
* call-agent.c (learn_cb): Special treatment when the issuer
certificate is missing.
diff --git a/sm/Makefile.am b/sm/Makefile.am
index 7d2705319..efbceb6de 100644
--- a/sm/Makefile.am
+++ b/sm/Makefile.am
@@ -39,8 +39,8 @@ gpgsm_SOURCES = \
certlist.c \
certdump.c \
certcheck.c \
- certpath.c \
- keylist.c \
+ certchain.c \
+ keylist.ccvs ta \
verify.c \
sign.c \
encrypt.c \
diff --git a/sm/certchain.c b/sm/certchain.c
index d1fca2bf3..73f75764d 100644
--- a/sm/certchain.c
+++ b/sm/certchain.c
@@ -1,4 +1,4 @@
-/* certpath.c - certificate chain validation
+/* certchain.c - certificate chain validation
* Copyright (C) 2001, 2002 Free Software Foundation, Inc.
*
* This file is part of GnuPG.
diff --git a/sm/gpgsm.h b/sm/gpgsm.h
index f50e5086a..93983bf10 100644
--- a/sm/gpgsm.h
+++ b/sm/gpgsm.h
@@ -186,7 +186,7 @@ int gpgsm_create_cms_signature (KsbaCert cert, GCRY_MD_HD md, int mdalgo,
char **r_sigval);
-/*-- certpath.c --*/
+/*-- certchain.c --*/
int gpgsm_walk_cert_chain (KsbaCert start, KsbaCert *r_next);
int gpgsm_is_root_cert (KsbaCert cert);
int gpgsm_validate_chain (CTRL ctrl, KsbaCert cert, time_t *r_exptime);