aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-09-04 12:12:42 +0000
committerDavid Shaw <[email protected]>2003-09-04 12:12:42 +0000
commit50fb4a28d30dc01018e26b55a67ac7d2d24d495f (patch)
tree3450fbef5481208c538b0191cb8353af41e71c91
parent* armor.c (parse_hash_header, armor_filter), g10.c (print_hex, print_mds), (diff)
downloadgnupg-50fb4a28d30dc01018e26b55a67ac7d2d24d495f.tar.gz
gnupg-50fb4a28d30dc01018e26b55a67ac7d2d24d495f.zip
* mds.test, sigs.test: Remove TIGER/192 and make SHA-256 optional (since
it might not be compiled in).
-rw-r--r--checks/ChangeLog5
-rwxr-xr-xchecks/mds.test12
-rwxr-xr-xchecks/sigs.test4
3 files changed, 11 insertions, 10 deletions
diff --git a/checks/ChangeLog b/checks/ChangeLog
index da211092f..cea53feb7 100644
--- a/checks/ChangeLog
+++ b/checks/ChangeLog
@@ -1,3 +1,8 @@
+2003-09-04 David Shaw <[email protected]>
+
+ * mds.test, sigs.test: Remove TIGER/192 and make SHA-256 optional
+ (since it might not be compiled in).
+
2003-07-10 David Shaw <[email protected]>
* Makefile.am: Add --no-permission-warning to avoid spurious
diff --git a/checks/mds.test b/checks/mds.test
index eb36193a4..a83c03a13 100755
--- a/checks/mds.test
+++ b/checks/mds.test
@@ -20,14 +20,12 @@ test_one ":1:" "D41D8CD98F00B204E9800998ECF8427E"
test_one ":2:" "DA39A3EE5E6B4B0D3255BFEF95601890AFD80709"
# RMD160
test_one ":3:" "9C1185A5C5E9FC54612808977EE8F548B2258D31"
-# TIGER
-if have_hash_algo "TIGER192"; then
- test_one ":6:" "24F0130C63AC933216166E76B1BB925FF373DE2D49584E7A"
+# SHA-256
+if have_hash_algo "SHA256"; then
+ test_one ":8:" "E3B0C44298FC1C149AFBF4C8996FB92427AE41E4649B934CA495991B7852B855"
else
- echo "Hash algorithm TIGER/192 is not installed (not an error)"
+ echo "Hash algorithm SHA-256 is not installed (not an error)"
fi
-# SHA-256
-test_one ":8:" "E3B0C44298FC1C149AFBF4C8996FB92427AE41E4649B934CA495991B7852B855"
# SHA-384
if have_hash_algo "SHA384"; then
test_one ":9:" "38B060A751AC96384CD9327EB1B1E36A21FDB71114BE07434C0CC7BF63F6E1DA274EDEBFE76F65FBD51AD2F14898B95B"
@@ -58,8 +56,6 @@ if have_hash_algo "SHA512"; then
test_one ":10:" "4DBFF86CC2CA1BAE1E16468A05CB9881C97F1753BCE3619034898FAA1AABE429955A1BF8EC483D7421FE3C1646613A59ED5441FB0F321389F77F48A879C7B1F1"
fi
-
[ "$failed" != "" ] && error "$failed failed for a..z"
exit 0
-
diff --git a/checks/sigs.test b/checks/sigs.test
index 0c5fcd3e6..38cabe64d 100755
--- a/checks/sigs.test
+++ b/checks/sigs.test
@@ -13,8 +13,8 @@ done
# documents.
hash_algo_list="ripemd160 sha1 md5"
-if have_hash_algo "TIGER192"; then
- hash_algo_list="$hash_algo_list tiger192"
+if have_hash_algo "SHA256"; then
+ hash_algo_list="$hash_algo_list sha256"
fi
for da in $hash_algo_list ; do