diff options
author | David Shaw <[email protected]> | 2004-11-05 03:45:06 +0000 |
---|---|---|
committer | David Shaw <[email protected]> | 2004-11-05 03:45:06 +0000 |
commit | 4509cb7b1c243135fd4c7cc5ed9c69cf8bfd2d45 (patch) | |
tree | 4cf475adb3939e0811457c24d9aedecd8f6c7c29 | |
parent | * plaintext.c (handle_plaintext): Don't try and create a zero-length (diff) | |
download | gnupg-4509cb7b1c243135fd4c7cc5ed9c69cf8bfd2d45.tar.gz gnupg-4509cb7b1c243135fd4c7cc5ed9c69cf8bfd2d45.zip |
* README, configure.ac: Add --enable-backsigs to enable the experimental
backsigs code.
-rw-r--r-- | ChangeLog | 5 | ||||
-rw-r--r-- | README | 10 | ||||
-rw-r--r-- | configure.ac | 9 |
3 files changed, 23 insertions, 1 deletions
@@ -1,3 +1,8 @@ +2004-11-04 David Shaw <[email protected]> + + * README, configure.ac: Add --enable-backsigs to enable the + experimental backsigs code. + 2004-10-28 Werner Koch <[email protected]> Released 1.3.92. @@ -614,7 +614,15 @@ support. This option allows to explicity disable the use of iconv. Note, that iconv is also disabled if getext has been disabled. - + + --enable-backsigs + Enables "backsigs" support. This is a currently + experimental solution to a subtle OpenPGP protocol + problem involving signing subkeys. It is + specified in the 2440bis drafts that will become + the new OpenPGP standard, but is not finalized yet + and has not had interoperability testing. Use at + your own risk. Installation Problems diff --git a/configure.ac b/configure.ac index d51e4507e..e9c0facda 100644 --- a/configure.ac +++ b/configure.ac @@ -131,6 +131,12 @@ AC_ARG_ENABLE(gnupg-iconv, gnupg_use_iconv=$enableval, gnupg_use_iconv=yes) AC_MSG_RESULT($gnupg_use_iconv) +AC_MSG_CHECKING([whether to enable the experimental backsigs code]) +AC_ARG_ENABLE(backsigs, + AC_HELP_STRING([--enable-backsigs], + [enable the experimental backsigs code]), + do_backsigs=$enableval, do_backsigs=no) +AC_MSG_RESULT($do_backsigs) dnl See if we are disabling any algorithms or features for a smaller dnl binary @@ -751,6 +757,9 @@ if test "$gnupg_use_iconv" = yes ; then AC_DEFINE(USE_GNUPG_ICONV,1,[Define to use the new iconv based code]) fi +if test "$do_backsigs" = yes ; then + AC_DEFINE(DO_BACKSIGS,1,[Define to enable the experimental backsigs code]) +fi AM_CONDITIONAL(ENABLE_CARD_SUPPORT, test "$card_support" = yes) |