aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-11-06 13:18:13 +0000
committerDavid Shaw <[email protected]>2004-11-06 13:18:13 +0000
commit42dfecadf76f12c7425794ade83714b1a05b6cf9 (patch)
treefcef26fc7f9bae9e9fa00bdcc9b764108ca13bab
parent* README, configure.ac: Add --enable-backsigs to enable the experimental (diff)
downloadgnupg-42dfecadf76f12c7425794ade83714b1a05b6cf9.tar.gz
gnupg-42dfecadf76f12c7425794ade83714b1a05b6cf9.zip
* configure.ac: Autodetect wldap32 on Windoze.
-rw-r--r--ChangeLog4
-rw-r--r--configure.ac12
2 files changed, 13 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 55f227766..05a075fa0 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2004-11-06 David Shaw <[email protected]>
+
+ * configure.ac: Autodetect wldap32 on Windoze.
+
2004-11-04 David Shaw <[email protected]>
* README, configure.ac: Add --enable-backsigs to enable the
diff --git a/configure.ac b/configure.ac
index e9c0facda..254aeb199 100644
--- a/configure.ac
+++ b/configure.ac
@@ -456,7 +456,6 @@ case "${host}" in
have_dosish_system=yes
need_dlopen=no
try_gettext="no"
- LDAPLIBS="-lwldap32"
;;
i?86-emx-os2 | i?86-*-os2*emx )
# OS/2 with the EMX environment
@@ -592,12 +591,19 @@ AC_SUBST(SRVLIBS)
# LDAPLIBS="-Lfoo -lbar"
if test "$try_ldap" = yes ; then
- for MY_LDAPLIBS in ${LDAPLIBS+"$LDAPLIBS"} "-lldap" "-lldap -llber" "-lldap -llber -lresolv"; do
+ for MY_LDAPLIBS in ${LDAPLIBS+"$LDAPLIBS"} "-lldap" "-lldap -llber" "-lldap -llber -lresolv" "-lwldap32"; do
_ldap_save_libs=$LIBS
LIBS="$MY_LDAPLIBS $NETLIBS $LIBS"
AC_MSG_CHECKING([whether LDAP via \"$MY_LDAPLIBS\" is present and sane])
- AC_TRY_LINK([#include <ldap.h>],[ldap_open("foobar",1234);],
+ AC_TRY_LINK([
+#ifdef _WIN32
+#include <winsock2.h>
+#include <winldap.h>
+#else
+#include <ldap.h>
+#endif
+],[ldap_open("foobar",1234);],
[gnupg_cv_func_ldap_init=yes],[gnupg_cv_func_ldap_init=no])
AC_MSG_RESULT([$gnupg_cv_func_ldap_init])