aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-04-17 00:06:04 +0000
committerDavid Shaw <[email protected]>2005-04-17 00:06:04 +0000
commit352db25580f6d4631bc9efd38d2d2387153883d0 (patch)
tree3cda93dd60bccdb4cb865bae10707ca35b874e83
parent* curl-shim.h, curl-shim.c (curl_escape, curl_free): Emulate (diff)
downloadgnupg-352db25580f6d4631bc9efd38d2d2387153883d0.tar.gz
gnupg-352db25580f6d4631bc9efd38d2d2387153883d0.zip
* configure.ac: Remove --disable-old-hkp - use new HKP handler for
--with-libcurl or --enable-fake-curl.
-rw-r--r--ChangeLog3
-rw-r--r--configure.ac14
2 files changed, 7 insertions, 10 deletions
diff --git a/ChangeLog b/ChangeLog
index 29d973eee..2ae7eaebc 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,8 @@
2005-04-16 David Shaw <[email protected]>
+ * configure.ac: Remove --disable-old-hkp - use new HKP handler for
+ --with-libcurl or --enable-fake-curl.
+
* configure.ac: Add --disable-old-hkp option that can be used
along with --with-libcurl to build the curl version of HKP.
diff --git a/configure.ac b/configure.ac
index e27f5aedd..b61b8dbde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -628,14 +628,14 @@ if test x"$fake_curl" = xyes ; then
else
# If we have neither FTP or HTTP defined, then don't bother to check
# for curl.
- if test x"$try_ftp" = xyes || test x"$try_http" = xyes ; then
- LIBCURL_CHECK_CONFIG([no])
+ if test x"$try_hkp" = xyes || test x"$try_ftp" = xyes || test x"$try_http" = xyes ; then
+ LIBCURL_CHECK_CONFIG([no],,[with_curl=yes])
fi
fi
-# Are we doing HTTP?
+AM_CONDITIONAL(WITH_CURL,test x"$with_curl" = xyes || test x"$fake_curl" = xyes)
-old_hkp=yes
+# Are we doing HTTP?
if test x"$try_http" = xyes ; then
if test x$libcurl_protocol_HTTP = xyes ; then
@@ -644,17 +644,11 @@ if test x"$try_http" = xyes ; then
if test x$libcurl_protocol_HTTPS = xyes ; then
AC_DEFINE(HTTPS_VIA_LIBCURL,1,[Define if HTTPS is handled via libcurl])
fi
-
- AC_ARG_ENABLE(old-hkp,
- AC_HELP_STRING([--disable-old-hkp],[disable old HKP processing code and use the new]),old_hkp=$enableval)
-
else
AC_SUBST(GPGKEYS_HTTP,"gpgkeys_http$EXEEXT")
fi
fi
-AM_CONDITIONAL(OLD_HKP,test x"$old_hkp" != xno)
-
# Are we doing FTP? We only do FTP if we have libcurl.
if test x"$try_ftp" = xyes && test x$libcurl_protocol_FTP = xyes ; then