aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-02-12 05:10:30 +0000
committerDavid Shaw <[email protected]>2003-02-12 05:10:30 +0000
commit257956b49023b0f2ab63d4f3d99c3df42a7ce122 (patch)
treef5438249b17b8bdce4b5e0c7cddd24e461331a00
parent* configure.ac: Do not set GNUPG_LIBEXECDIR in ./configure, so that (diff)
downloadgnupg-257956b49023b0f2ab63d4f3d99c3df42a7ce122.tar.gz
gnupg-257956b49023b0f2ab63d4f3d99c3df42a7ce122.zip
* Makefile.am: Use a local copy of libexecdir along with @PACKAGE@ as
GNUPG_LIBEXECDIR so it can be easily overridden at make time.
-rw-r--r--g10/ChangeLog5
-rw-r--r--g10/Makefile.am4
2 files changed, 8 insertions, 1 deletions
diff --git a/g10/ChangeLog b/g10/ChangeLog
index 288dd1558..42228f986 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,3 +1,8 @@
+2003-02-11 David Shaw <[email protected]>
+
+ * Makefile.am: Use a local copy of libexecdir along with @PACKAGE@
+ as GNUPG_LIBEXECDIR so it can be easily overridden at make time.
+
2003-02-04 David Shaw <[email protected]>
* armor.c (parse_hash_header, armor_filter): Accept the new SHAs
diff --git a/g10/Makefile.am b/g10/Makefile.am
index d84707af8..83349d411 100644
--- a/g10/Makefile.am
+++ b/g10/Makefile.am
@@ -22,7 +22,9 @@ INCLUDES = -I.. -I$(top_srcdir)/include -I$(top_srcdir)/intl
EXTRA_DIST = options.skel
# it seems that we can't use this with automake 1.5
#OMIT_DEPENDENCIES = zlib.h zconf.h
-LDFLAGS = @LDFLAGS@
+LDFLAGS = @LDFLAGS@
+libexecdir = @libexecdir@/@PACKAGE@
+CFLAGS = @CFLAGS@ -DGNUPG_LIBEXECDIR="\"$(libexecdir)\""
needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
#noinst_PROGRAMS = gpgd